milan-arzneimittel.com - ISO-8859-1 CSS ignored on web page in UTF16-LE

RESOLVED FIXED

Status

RESOLVED FIXED
15 years ago
3 years ago

People

(Reporter: mozilla, Unassigned)

Tracking

Details

(URL)

Attachments

(4 attachments, 2 obsolete attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6b) Gecko/20031208
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6b) Gecko/20031208

The russian Webpage at http://www.milan-arzneimittel.com/ru/main.htm should be
formatted according to the Style sheet given in
http://www.milan-arzneimittel.com/ru/BSC.css .
This works fine with the english and german Version of that page (ANSI), but not
with the russian Version (Unicode).

This works fine with IE...



Reproducible: Always

Steps to Reproduce:
1. Open the Webpage http://www.milan-arzneimittel.com
2. Go to the russian section.

Actual Results:  
Style Sheet is not applied

Expected Results:  
The russian Pages should be formatted exactly like the german and english
Versions accessible from http://www.milan-arzneimittel.com .

Comment 1

15 years ago
it seems to wfm using 20040113 on Win2k, it renders the same as with german &
english pages.
Can you attach a screenshot ?

Can you also then test pre-1.6 nightly build (1.6 should be out soon, so it's
fairly stable):
http://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/latest-1.6/
Works for me. I'll wait to see if anyone can confirm it.
Oh, and my build ID

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040107
-> WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

15 years ago
Created attachment 139014 [details]
example for the described problem

3 times the same section of the Page:

1. english - correctly displayed by Mozilla
2. russian - Mozilla, style sheet ignored
3. russian - correctly displayed by IE
Which encoding is selected in "View | Character Coding" when you see the
problem?  Which encoding is selected when you don't?
Actually, the better way to tell the encoding is right click -> this frame ->
view frame info.

However, this is probably a duplicate of bug 230360.  If you try a trunk build,
is the problem fixed?
Status: RESOLVED → UNCONFIRMED
Depends on: 230360
Resolution: WORKSFORME → ---
er, bug 230660
Depends on: 230660
No longer depends on: 230360
Actually, never mind, I can still reproduce this with current builds.

The URLs to compare (contrary to the original bug report, which gave the wrong
URLs) are:

http://www.milan-arzneimittel.com/en/index2.htm
http://www.milan-arzneimittel.com/ru/index2.htm
Status: UNCONFIRMED → NEW
Ever confirmed: true
It's worth noting that the Russian page, according to page info, gives an
incorrect encoding in the HTTP header, but we somehow override that and
determine that it's UTF16-LE.
Summary: CSS Style Sheets are ignored on Webpages using Unicode → ISO-8859-1 CSS ignored on web page in UTF16-LE claiming to be Windows-1252
Created attachment 139039 [details]
version of testcase in iso-8859-1 (no problem)
Created attachment 139040 [details]
testcase (HTML in UTF-16)
Attachment #139038 - Attachment is obsolete: true
Created attachment 139041 [details]
testcase without problem (HTML in iso-8859-1)
Attachment #139039 - Attachment is obsolete: true
Summary: ISO-8859-1 CSS ignored on web page in UTF16-LE claiming to be Windows-1252 → ISO-8859-1 CSS ignored on web page in UTF16-LE
This keeps coming up...  The problem is that there is no charset from the http
headers, no charset in an @charset rule, no charser set on the linking element.
 At that point, we fall back on the document charset.  Trying to decode ascii
data in UTF-16LE obviously gives us no usable data.

There is no way to fix the few pages like this (that send different parts of the
page in different encodings without specifying encodings anywhere) without
breaking the many other sites that send sheets in the same encoding as the page
and specify no encodings.

As for comment 10, the reason we detect the page as UTF-16LE is that we trust
the BOM over meta tags (see the list at
http://lxr.mozilla.org/seamonkey/source/htmlparser/public/nsIParser.h#96) and
the page has a valid UTF-16LE BOM.

I would say this is evang.
Assignee: dbaron → other
Component: Style System (CSS) → Other
Product: Browser → Tech Evangelism
QA Contact: ian → other
Version: Trunk → unspecified

Comment 17

14 years ago
Conforming summary to TFM item 10 at 
http://www.mozilla.org/projects/tech-evangelism/site/procedures.html#file-new
Summary: ISO-8859-1 CSS ignored on web page in UTF16-LE → milan-arzneimittel.com - ISO-8859-1 CSS ignored on web page in UTF16-LE
404
Status: NEW → RESOLVED
Last Resolved: 15 years ago10 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.