Tab into a text input with onfocus=this.blur hangs browser

RESOLVED DUPLICATE of bug 232368

Status

()

Core
Event Handling
--
critical
RESOLVED DUPLICATE of bug 232368
15 years ago
15 years ago

People

(Reporter: Leon Out, Unassigned)

Tracking

({hang, testcase})

Trunk
hang, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7a) Gecko/20040112 Firebird/0.8.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7a) Gecko/20040112 Firebird/0.8.0+

Tabbing into a text input formfield that has onfocus="this.blur()" hangs the
browser in nightly builds since at least mid-December, requiring a force quit.
I've reproduced this with the most recent nightlies of Firebird (on MacOS X) and
Mozilla (on Windows 2000). This problem does not exist in Firebird 0.7 on either
platform or in Mozilla 1.3 on Windows 2000 (although Mozilla 1.3 lets you type
in the field after tabbing in!).

Clicking in the text field with onfocus="this.blur()" does not cause a problem
in any case.


Reproducible: Always

Steps to Reproduce:
1. Go to http://www.leonout.com/mozilla/blur.html
2. Click in the first text field.
3. Press Tab

Actual Results:  
The browser hangs and must be forced to quit.

Expected Results:  
blur()ed the text field and returned focus to the page body.
Not JS engine.
Assignee: general → events
Component: JavaScript Engine → Event Handling
QA Contact: PhilSchwartau → ian
Summary: Tab into a text input with onfocus=this.blur hangs browser → Tab into a text input with onfocus=this.blur hangs browser
Whiteboard: DUPEME

Comment 2

15 years ago
dupe of bug 53579? Though no hang is mentioned in that bug
(Reporter)

Comment 3

15 years ago
This may be related to 53579, but I believe it's a new bug, since it's in the
nightlies but doesn't exist in the latest milestones.
So I am guessing that calling this.blur() happens before the content is
completely focused by the ESM or something... and then the ESM gets confused.

Confirming and attaching the testcase.  bryner, any chance you could look into this?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: DUPEME

Comment 6

15 years ago
dupe of a newer bug with more info -- "Hang when tab into input element with
onBlur handler"

*** This bug has been marked as a duplicate of 232368 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Keywords: hang, testcase
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.