weird caret behavior in all textbox when \0002 is inserted

RESOLVED EXPIRED

Status

SeaMonkey
General
RESOLVED EXPIRED
15 years ago
13 years ago

People

(Reporter: Sekundes, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7a) Gecko/20040108
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7a) Gecko/20040108

I think most escape characters inserted would make this issues too.

Reproducible: Always

Steps to Reproduce:
1.Copy a \0002 character from attachment.
2.Paste it in any textbox widget rendered by Mozilla.
3.Typing anything.
(Reporter)

Comment 1

15 years ago
Created attachment 139007 [details]
0002 character
When I follow the steps to reproduce I see nothing weird -- I can type just
fine; the \0002 is rendered like the "unknown character" box and acts just like
any other char. 

Linux trunk build 2004-01-11-07.
(Reporter)

Comment 3

15 years ago
how about highlight the characters you have typed?
It's hard for me to explain it well as the characters randomly disappeared and
the caret is focus on the 2nd last character but not the expected last one.

Will the locale settings affect this? I'm an asian user.

Comment 4

15 years ago
I see this in Mozilla 2004012608.  To reproduce copy about two dozen into the
text box.  The caret is at the wrong spot at the end of the charecters and
highlighting is also rendered wrong.

Comment 5

14 years ago
This bug still affects Mozilla.  Seen on Windows XP SP2 with Mozilla/5.0
(Windows; U; Windows NT 5.1; en-US; rv:1.8a4) Gecko/20040914

The escape character creates problems in the following areas:
 - Location bar (for instance, try the escape character a few times, type some
text, and delete some text - the Location bar does not correctly refresh)
 - Textboxes, as suggested by the reporter
 - View Source (I could not see the escape character in the attachment, either
in the browser or in the View Source window)
 - Text selection - in the browser, and in the View Source window, it's not easy
to select the escape charcter... selection tends to begin after the character
rather than before it
Product: Browser → Seamonkey
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.