Right mouse button context menus will always crash mozilla

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
blocker
RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: osavill, Unassigned)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7a) Gecko/20040112
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7a) Gecko/20040112

It appears that the following actions are guaranteed to blow Mozilla away :

1) Bring up a right context mouse button menu. Any context menu will do, not
just the one from the actual viewed web page.
2) Click the left button <b>outside</b> that menu

Result:
 Mozilla just dissappears !

This is similar to Bug 183827. I felt it required a new OR since that OR selects
a specific context menu and selects an option from within that menu. Furthermore
te reporter states that it is intermittent whereas this one is consistent.

Reproducible: Always

Steps to Reproduce:
1.Bring up a right context mouse button menu. Any context menu will do, not just
the one from the actual viewed web page.
2.Click the left button <b>outside</b> that menu
3.

Actual Results:  
Mozilla just disappears !

Expected Results:  
The context menu should disappear.
(Reporter)

Comment 1

14 years ago
P.S. This does not happen with Moz 2003121808
(Reporter)

Comment 2

14 years ago
Launcing Mozilla from a shell produces the following output:

/opt/mozilla/run-mozilla.sh: line 451: 17459 Segmentation fault      "$prog" ${1
                               +"$@"}

Comment 3

14 years ago
Is this on a gtk1 or gtk2 build of mozilla ?
Does this appear in builds from today (Jan 14)? If not, this is a duplicate of
bug 230380 

Comment 5

14 years ago
WFM on a gtk2 trunk build that I pulled from the cvs maybe 4-6 hours ago. 

Comment 6

14 years ago
Reporter, I'm assuming this bug is now WFM along with the other two crashers you
reported at the same time, 230874 and 230876.  If not, please reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.