"Set Default Browser" creates backup registry entries

RESOLVED INVALID

Status

()

Firefox
Preferences
--
minor
RESOLVED INVALID
15 years ago
12 years ago

People

(Reporter: Michael O., Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6) Gecko/20040114 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6) Gecko/20040114 Firebird/0.7+

When setting Firebird to be the default browser on Win98, the following entries
are created in registry key [HKEY_LOCAL_MACHINE\Software\Mozilla\Desktop]:

"HKEY_LOCAL_MACHINE\\Software\\Classes\\http\\shell\\open\\ddeexec"="\"%1\",,-1,0,,,,"
"HKEY_LOCAL_MACHINE\\Software\\Classes\\http\\shell\\open\\ddeexec\\Application"="Mozilla
Firebird"
"HKEY_LOCAL_MACHINE\\Software\\Classes\\http\\shell\\open\\ddeexec\\Topic"="WWW_OpenURL"

It's obvious that instead of creating ddeexec entries in the proper keys,
Firebird is creating erroneous entries with the path as the value name.

I do not have the resources handy to determine if this behavior also occurs on
WinXP.

Reproducible: Always

Steps to Reproduce:
1. Set Mozilla Firebird as the default browser in Windows.
2. View the Windows Registry, key [HKEY_LOCAL_MACHINE\Software\Mozilla\Desktop]
(Reporter)

Updated

15 years ago
Flags: blocking0.8?
(Reporter)

Comment 1

14 years ago
Addendum -- Firebird created another entry while setting a new icon for HTML files:

"HKEY_LOCAL_MACHINE\Software\Classes\MozillaHTML\DefaultIcon"="E:\icons\filetype\html.ico,0"

But the value is the path to the old icon. Is Firebird supposed to be saving
backup information in the HKEY_LOCAL_MACHINE\Software\Mozilla\Desktop key?
Does this happen using Mozilla as well?  I need to test this when I get a 
chance, but I'm not sure what those should be
Assignee: blake → bugs
(Reporter)

Comment 3

14 years ago
Yes, it happens with Mozilla 1.6 as well. Here's the full list of entries
created in [HKEY_LOCAL_MACHINE\Software\Mozilla\Desktop] when switching from one
default (Firebird) to another (SeaMonkey):

"HKEY_LOCAL_MACHINE\\Software\\Classes\\MozillaHTML\\shell\\open\\command"="C:\\INTERNET\\MOZILL~1\\MOZILL~1.EXE
-url \"%1\""
"HKEY_LOCAL_MACHINE\\Software\\Classes\\MozillaHTML\\DefaultIcon"="C:\\INTERNET\\MOZILL~1\\MOZILL~1.EXE,0"
"HKEY_LOCAL_MACHINE\\Software\\Classes\\MozillaXML\\shell\\open\\command"="C:\\INTERNET\\MOZILL~1\\MOZILL~1.EXE
-url \"%1\""
"HKEY_LOCAL_MACHINE\\Software\\Classes\\MozillaXML\\DefaultIcon"="C:\\INTERNET\\MOZILL~1\\MOZILL~1.EXE,0"
"HKEY_LOCAL_MACHINE\\Software\\Classes\\MozillaXHTML\\shell\\open\\command"="C:\\INTERNET\\MOZILL~1\\MOZILL~1.EXE
-url \"%1\""
"HKEY_LOCAL_MACHINE\\Software\\Classes\\MozillaXHTML\\DefaultIcon"="C:\\INTERNET\\MOZILL~1\\MOZILL~1.EXE,0"
"HKEY_LOCAL_MACHINE\\Software\\Clients\\StartMenuInternet"="MOZILL~1.EXE"
"HKEY_LOCAL_MACHINE\\Software\\Classes\\http\\shell\\open\\command"="C:\\INTERNET\\MOZILL~1\\MOZILL~1.EXE
-url \"%1\""
"HKEY_LOCAL_MACHINE\\Software\\Classes\\http\\DefaultIcon"="C:\\INTERNET\\MOZILL~1\\MOZILL~1.EXE,0"
"HKEY_LOCAL_MACHINE\\Software\\Classes\\https\\shell\\open\\command"="C:\\INTERNET\\MOZILL~1\\MOZILL~1.EXE
-url \"%1\""
"HKEY_LOCAL_MACHINE\\Software\\Classes\\https\\DefaultIcon"="C:\\INTERNET\\MOZILL~1\\MOZILL~1.EXE,0"
"HKEY_LOCAL_MACHINE\\Software\\Classes\\ftp\\shell\\open\\command"="C:\\INTERNET\\MOZILL~1\\MOZILL~1.EXE
-url \"%1\""
"HKEY_LOCAL_MACHINE\\Software\\Classes\\ftp\\DefaultIcon"="C:\\INTERNET\\MOZILL~1\\MOZILL~1.EXE,0"

They're all copies of the old values. Now that I know they aren't misplaced
entries, I'm just curious to know if the copies are useful in any way. I've
never seen an option to revert the default browser setting.

Removing my blocking0.8? flag since this now appears to be a minor issue.
Flags: blocking0.8?
(Reporter)

Updated

14 years ago
Severity: normal → minor
Summary: "Set Default Browser" creates erroneous registry entries → "Set Default Browser" creates backup registry entries

Comment 4

14 years ago
I use Windows 2k and Firefox 0.9 and i have those DDEExec-Entries, too. This
causes an error-message when i try to open an url via start/execute. After that
Firefox is opening and shows me the correct URL.

Deleting the DDEExec-Entry in the Registry
HKEY_CLASSES_ROOT\\http\\shell\\open\\ddeexec
solves the problem.

Comment 5

14 years ago
These backups are used when Mozilla is uninstalled, or (in the case Mail/News) 
when the checkbox for "make me the default mailer" is unchecked.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.