Closed Bug 230963 Opened 16 years ago Closed 11 years ago

Compile mozilla for OS X with IBM's new compiler.

Categories

(SeaMonkey :: Build Config, enhancement)

PowerPC
macOS
enhancement
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: Usul, Unassigned)

References

()

Details

User-Agent:       Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0)
Build Identifier: 

It would be interesting to see if mozilla build with IBM's XLC compiler for 
MacOS X is Faster then the one build with gcc and if it is also smaller. Since 
Mozilla is C/C++ adding the new compiler should not be too much work.
If smaller and faster, switching to XLC would be interesting for release builds.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
ccing intersting/interested parties.
On AIX I've seen wget/gzip compiled with gcc and XLC. the resulting binaries
where 1/2 the size when compiled with XLC.
URL: NA
IIRC XLC is only for G4/G5.  

And it's $499 as per:
http://forums.macnn.com/showthread.php?s=&threadid=197118#post1787296

among other places.

Would be very interesting to see.  Might make for a great enhancement on OS X.
Well, I got access to the compiler and tried it out.  After a few iterations of
code changes, it finally stopped in mozilla/content/html/content/src, where
'ranlib' crashed with a "bus error".  Haven't been able to get past that.  Brian
got stuck at the same point working independently.

It seems that this compiler handles templates in a strange way, and that might
be giving ranlib the headache.  The compiler provides some template related
command line switches, but those make the build break sooner!

Also, of the stuff that did get built, the IBM compiler produced shared libs and
executables quite a bit larger than GCC.  And since not much of consequence got
built, I was unable to test performance.

So, my initial perception of this compiler is that it's not worth it.  The time
spent trying to get this to build Mozilla would be better spent working with
GCC.  Of course, if someone else wants to give this a shot, I'd be happy to
provide my code changes up to this point.
Product: Browser → Seamonkey
Anyone tried with an updated version of the compiler and updated sources ?
resolving as WONTFIX based on Comment #3
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.