Ignoring RFC 1123, Section 5.2.17 (Domain Literals)

RESOLVED DUPLICATE of bug 133016

Status

RESOLVED DUPLICATE of bug 133016
15 years ago
14 years ago

People

(Reporter: aal, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007

When e-mail address in the reader window uses "Domain Literals" form (e.g.
postmaster@[192.168.1.1]), the reader does not understand last bracket as a part
of address. "Copy e-mail address", "Compose mail to", etc., operations use
cutted and unvalid <postmaster@[192.168.1.1>.

See also RFC 1123, Section 2.1, RFC 1123, Section 5.2.17, RFC 2821, Section 4.1.3.


Reproducible: Always

Steps to Reproduce:
1. Send message to yourself mentioning postmaster@[A.B.C.D] in text and|or CC:.
  A.B.C.D should be your SMTP server IP-address.
2. Try to compose new nessage using highlighted postmaster@[A.B.C.D] in received
   message
3. Say oops.

Actual Results:  
To: postmaster@[A.B.C.D

Expected Results:  
To: postmaster@[A.B.C.D]


http://dsbl.org/rfcinfo

Comment 1

14 years ago
The problem here is not "ignoring RFC 1123."  The problem is, the URL recognizer 
is conservative and deliberately avoids certain types of characters.  See the 
example at bug 218287 for why brackets, in particular, *should* be avoided.

One way to make this always work is to enclose the URL in angle brackets:
  <mailto:postmaster@[A.B.C.D]>
is completely recognized by Mozilla, and by other mail programs as well.

See bug 133016 comment 23 for why this is unlikely to be changed.

*** This bug has been marked as a duplicate of 133016 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.