If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

browser crash(Firebird 0.7 and Mozilla 1.5) if I try to hide a div using JavaScript that contains an <input type="file">

RESOLVED DUPLICATE of bug 203041

Status

()

Core
DOM
--
critical
RESOLVED DUPLICATE of bug 203041
14 years ago
14 years ago

People

(Reporter: Cosmin Budinschi, Assigned: Blake Ross)

Tracking

({crash, testcase})

Trunk
x86
All
crash, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

I have a page that contains some <div>s that are displayed or are closed
depending on which buttons are pressed. When I try to hide a div that contains
an an  input element of type file the browser closes. The same thing happens
with Mozilla

Reproducible: Always

Steps to Reproduce:
<html>
<head>
	<script language="JavaScript1.2">
	function show_div(id_div)
	{
	document.getElementById(id_div).style.display = "block";
	}

	function hide_div(id_div)
	{
	document.getElementById(id_div).style.display = "none";
	}
	</script>
	<style>div.op{background-color:#fff;display:none;position:absolute; width:
500px; height: 300px;top:21%;left:35%;padding:1px; border-top: 2px solid
#ddd;border-left: 2px solid #ddd; border-right: 2px solid #666; border-bottom:
2px solid #666;}</style>
</head>
<body>
<div id="id1" class="op">
<input type="file" name="some_file">
<button onclick='hide_div("id1")'>Hide DIV</div>
</div>
<button onclick='show_div("id1")'>Show DIV</div>
</body>
</html>
=======================================================================
Steps to follow:
1.Put the above code in a html file and open it with either Mozilla 1.5 or
Firebird 0.7.
2.Click the "Show DIV" button
3.Click the "Hide DIV" button
Actual Results:  
On Red Hat Linux 9.0 both Mozilla and Firebird close after I press the "Hide
DIV" button
On Windows 98(only tested with Firebird) after I prees the "Hide DIV" button a
system notice apear saying "This program has performed an illegal operation and
will be shutdown"

Expected Results:  
1.it shouldn't crush
2.it should have hide the div

I must mention that if I put anything besides the <input type="file"> element
the browser behaves as it should(it doesn't crush, the div is hidden(closed))

I use the "Orbit Blue" theme but the browser behaves the same with the default theme
a stacktrace would be useful here
Component: General → DOM
Product: Firebird → Browser
Version: unspecified → Trunk

Comment 2

14 years ago
Created attachment 139118 [details]
Reporters testcase (minimized)

Updated

14 years ago
Keywords: testcase

Comment 3

14 years ago
Confirming with 20040115 (WinXP).
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

14 years ago
Created attachment 139119 [details]
Even smaller testcase

No crash if position:absolute is removed from the div.

Updated

14 years ago
Keywords: crash
OS: Linux → All

Comment 5

14 years ago
Created attachment 139124 [details]
strace (on Windows)

Comment 6

14 years ago
Duplicate of bug 203041?

Comment 7

14 years ago

*** This bug has been marked as a duplicate of 203041 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 8

14 years ago
talkback using Mozilla 1.5: TB28916571M
also crashing with current nightly.

Comment 9

14 years ago
Confirming with 

Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.7a) Gecko/20040116

 
You need to log in before you can comment on or make changes to this bug.