Windows installer has problems when TEMP is not set properly.

VERIFIED DUPLICATE of bug 25101

Status

SeaMonkey
Installer
P3
major
VERIFIED DUPLICATE of bug 25101
19 years ago
14 years ago

People

(Reporter: Michael R. Decker, Assigned: Sean Su)

Tracking

Trunk
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
When I try to run the installation program (mozilla-win32-installer-M12.exe) I get the following error message:  "1157 : Could not load C:\WINDOWS\TEMP\core.ns\bin\xpistub.dll"  I am running Windows95 4.00.950 B on a P166MMX Machine with 48 MB RAM.  Other, pre-M12, binaries have been installed on this machine with few problems.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 1

19 years ago
How much disk space do you have on your C: drive before installation starts?
(The installer does not correctly calculate all the disk space required
depending on what's being installed).
(Reporter)

Comment 2

19 years ago
I doubt if it would be a lack of hard drive space causing the problem; I have
1.71 GB of space remaining.
(Assignee)

Comment 3

19 years ago
When you get the error message, can you task switch to the desktop and verify
that the xpistub.dll file exists in the given location?  If it does exist, can
you tell me its size?

Also, if you have not done this, can you run a scandisk on your system just to
make sure it is not a file system problem?
(Assignee)

Comment 4

19 years ago
grace, have you been able to reproduce this problem?  If you can't, I'd like to
close this as worksforme and have someone reopen if the problem persists in a
reproduceable way for us.

Comment 5

19 years ago
I cannot reproduce this on my 166 Win98 machine nor the Win95/NT machines.  I do
xpistub.dll is present in my temp/~~ directory.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 6

19 years ago
marking as worksforme.  Please reopen if you are still having problems.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 7

19 years ago
worksforme
(Reporter)

Comment 8

19 years ago
I have reformatted my hard drive, re-installed Win95, and downloaded the installer program.  I task switched from the installer andI have checked the c:\windows\temp\core.ns\bin directory and xpistub.dll is 21 KB.  However, the installation program still gives me the same error message.
(Assignee)

Updated

19 years ago
Severity: blocker → major
Status: VERIFIED → REOPENED
Target Milestone: M14
(Assignee)

Comment 9

19 years ago
reopening bug, but downgrading the severity.  This problem arises when the TEMP
environment variable is not set.
(Assignee)

Updated

19 years ago
Status: REOPENED → ASSIGNED
(Assignee)

Updated

19 years ago
Resolution: WORKSFORME → ---
(Assignee)

Comment 10

19 years ago
clearing the resolution of worksforme.

Comment 11

19 years ago
Clearing WORKSFORME resolution due to reopen.
(Assignee)

Comment 12

19 years ago
updating the summary field to be more precise.
Summary: Installation hangs → Windows installer has problems when TEMP is not set properly.
(Assignee)

Comment 13

19 years ago
This happens to be the same bug as 25101, which was fixed by dougt.


*** This bug has been marked as a duplicate of 25101 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → DUPLICATE

Comment 14

19 years ago
2000-01-28-09-M14/ build
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.