If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mozilla needs to make up its mind about how to display an unmapped character entity

RESOLVED WORKSFORME

Status

Core Graveyard
GFX: Gtk
RESOLVED WORKSFORME
14 years ago
9 years ago

People

(Reporter: tenthumbs, Assigned: blizzard)

Tracking

({testcase})

Trunk
x86
Linux
testcase

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 07/01)

Attachments

(4 attachments)

(Reporter)

Description

14 years ago
I have a simple test page which has some unmapped character entities. On initial
load it uses the '?' character which is fine. If I scroll down and then back up,
it decides that it's found a glyph from a font and uses it but does not reformat
the table so the glyph is badly misplaced. If I reload the page, then mozilla
goes back to '?'. If I scroll down and up, mozilla uses the glyph it found but
this time it's laid out properly.

Attachments upcoming.
(Reporter)

Comment 1

14 years ago
Created attachment 139130 [details]
test page
(Reporter)

Comment 2

14 years ago
Created attachment 139131 [details]
initial load, note U+0081
(Reporter)

Comment 3

14 years ago
Created attachment 139132 [details]
scroll down and up
(Reporter)

Comment 4

14 years ago
Created attachment 139133 [details]
reload, scroll down, scroll up
Assignee: nobody → blizzard
Component: Layout: Fonts and Text → GFX: Gtk
QA Contact: core.layout.fonts-and-text → ian
(Assignee)

Updated

14 years ago
Blocks: 172768

Updated

14 years ago
Keywords: testcase

Comment 5

14 years ago
I can't reproduce the behavior on 1.6 (gtk2 + xft). Is your build an Xft build? 
(Reporter)

Comment 6

14 years ago
Neither gtk2 nor Xft, just my own debug trunk build.

Comment 7

14 years ago
Then (if you built your build without Xft enabled), why did you mark this bug as
 blocking bug 172768? Bug 172768 is for Xft-related bug only.  
No longer blocks: 172768
(Reporter)

Comment 8

14 years ago
I didn't.

dbaron@dbaron.org changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
         AssignedTo|nobody@mozilla.org          |blizzard@mozilla.org
          Component|Layout: Fonts and Text      |GFX: Gtk
          QAContact|core.layout.fonts-and-      |ian@hixie.ch
                   |text@bugs                   |


blizzard@mozilla.org changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
OtherBugsDependingO|                            |172768
              nThis|                            |

Comment 9

10 years ago
Does this bug still occur in a recent trunk build?
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
Whiteboard: CLOSEME 07/01
Testcase is WFM, current Firefox trunk on Linux.

-> WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.