Privacy Options Reorganization

RESOLVED DUPLICATE of bug 191524

Status

()

P1
normal
RESOLVED DUPLICATE of bug 191524
15 years ago
12 years ago

People

(Reporter: bugs, Assigned: bugzilla)

Tracking

unspecified
Firefox1.0beta
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

It can be difficult to find out where to configure certain options for specific
features, such as Downloading, when the retention window option is in Privacy
rather than in Downloads. The reasons why it's not in Downloads are good and bad:

Good: The Downloads file list is a privacy matter, it represents a log of files
that have been downloaded that the user may not want others to know about and
may like to easily clear. 
Bad: The Download retention window options would not easily fit into the
Downloads panel as it exists today. 

Other problems with Privacy include the inability to easily reset options
quickly without opening the dialog, this might be something that merits a
"Tools" menu item ("Clean Up Privacy Data") attached to a dialog (which can be
disabled) that lists items to be cleaned. 

The privacy options panel could then be redeveloped. I don't know exactly what
needs to happen here but here's something for sure:

- there needs to be an easy path to clear a subset of privacy data that varies
from user to user (some users want history, cache, downloads, others want
history, cache, downloads, cookies)... the current UI offers this. 
- more consistency in placement of UI is desirable. 

If the feature specific options are farmed out to more relevant panels, the
Privacy Panel itself could disappear and become a home to options that don't fit
anywhere else.
-> me. 
Status: NEW → ASSIGNED
Component: General → Preferences
I've added a prototype UI design for this reorganization to the URL field of
this bug. 
This reorg sends some things that are not commonly perceived as "Privacy"
options to more logical locations in the Options window... such as download
retention, and cache. Things people generally consider as privacy concerns
(tracking data from history, forms, passwords and cookies) are kept. The
one-stop privacy clear all is kept but reorganized into a dialog which is also
available from the menus and a keybinding. One keybinding opens the dialog, the
same keybinding with the shift modifier causes the last selected action to be
performed silently. Good to do quickly and discretely before you hand your
computer over to someone else. 
Priority: -- → P3
Target Milestone: --- → Firebird1.0

Comment 4

15 years ago
Created attachment 143955 [details]
A brief proposal

Just a proposal: what about putting some kind of "clean all data" item under
the "file" menu (as Opera does). I am not a great fan of Opera but I like their
"shortcuts" in their "file" menu...

See the attached PNG screenshot from Opera...

Salvatore

Comment 5

15 years ago
Comment on attachment 143955 [details]
A brief proposal

Just a proposal: what about putting some kind of "clean all data" item under
the "file" menu (as Opera does). I am not a great fan of Opera but I like their
"shortcuts" in their "file" menu...

See the attached PNG screenshot from Opera...

Salvatore

Updated

14 years ago
QA Contact: mconnor
Priority: P3 → P1
Target Milestone: Firefox1.0 → Firefox1.0beta
Assignee: bugs → firefox
Status: ASSIGNED → NEW
(Assignee)

Comment 7

14 years ago
I'm handling this in 191524.

*** This bug has been marked as a duplicate of 191524 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

14 years ago
Flags: blocking-aviary1.0+
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.