Multiple POP Accounts - Can't Send New Email Message if One Server Is Inaccessable

RESOLVED INVALID

Status

SeaMonkey
MailNews: Message Display
--
major
RESOLVED INVALID
14 years ago
13 years ago

People

(Reporter: Art Parmet, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040113

I have two POP accounts configured. If I compose an email with the second
account and the first POP mail account in the list is down, Mozilla will not
send the message. The dialog box indicates that the message couldn't be sent
because the first mail server is inaccessable. Both POP mail accounts have
different mail server settings.
Mozilla 1.5.1 and 1.6 (official releases). MacOS 10.2.8

Reproducible: Always

Steps to Reproduce:
1. Compose new mail message using second mail account in list.
2. Insure first mail server account is inaccessable (I can do this by turning
off my VPN).
3. Hit Send button.

Actual Results:  
Mozilla will reply with a dialog bog that the first mail server in the list is
inaccesaable and won't send the message. 

No crash.

Expected Results:  
Only check the mail server for which the message is being targeted. Ignore the
status of the other one as it is not being used.

Standard Mozilla supplied theme.

Comment 1

14 years ago
In Mailnews, go to Edit --> Mail & Newsgroups Account Settings --> {2nd Account}
--> Server Settings, and click the "Advanced" Button.  Do you have the smtp
server for the second or first account selected?  Are there two selections
available? (If not, change in "Outgoing Server" pref page.)  If you have the
first account's smtp or "always use default" selected, does changing it allow
you to send mail?

Comment 2

14 years ago
From reporter via email:
----------
Before posting the Bugzilla report, I did play around with the advanced settings
and changed the default SMTP server but got the same result.

For this test, I was sending email from account # 2 (not the default). When I
checked the advanced SMTP settings, there was only a choice for the default SMTP
server (account #1), or the account #1 server by name directly. There was no
popup menu option for account #2. Account #1 is the one where I connect via a
VPN so I can shut this connection down to test.

I switched the settings so that account #2 is the default. I set account #1 so
it uses it's own SMTP account and not the default (account #2). Same results if
account #1 connection is down and I attempt to send email from account #2.

I did notice that after setting account #2 as the default, the advanced SMTP
settings option popup menu didn't change for any of the accounts. There is only
the option for the default server or for account #1. Account #2 never shows up
as an optional server.

I did quit and relaunch Mozilla and got the same results.

FWIW - I do have two other servers configured, one for public netnews and one
for Netscape netnews. Neither of servers show up as an option in any of the five
advanced SMTP settings. 
------------

It sounds like you need to go to Edit --> Mail & Newsgroups Account Settings -->
Outgoing Server (SMTP), click on the Advanced button there, and select Add to
configure new individual smtp servers for any additional mail accounts beyond
the first.  To find out what the server is for a particular mail account, visit
the ISP's website help section or instructions.  Once you do this, these
additional smtp servers will be available for use in the previously mentioned
Advanced menu under each individual account.

If this solves your problem, please make a note in the bug, or mark it as
Invalid (not a bug).  If not, please describe any changed symptoms after
creating and selecting the new, correct smtp server for the 2nd account.

But 170520 is a bug about specifying the smtp server in the new account wizard.

Comment 3

14 years ago
invalid per reporter email
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.