[CURRENCY] perform currency conversions

VERIFIED FIXED in 2.6

Status

--
enhancement
VERIFIED FIXED
15 years ago
9 years ago

People

(Reporter: alex, Assigned: ian)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: 

I have added the commands currency and currencies to the Stock.bm bot module 
to provide current currency conversions

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

15 years ago
Created attachment 139197 [details]
The revised Stock.bm bot module
(Reporter)

Comment 2

15 years ago
Created attachment 139199 [details]
Revised Stock.bm to display large currency conversions correctly
Attachment #139197 - Attachment is obsolete: true
(Assignee)

Comment 3

15 years ago
Cool. I want to get this for 2.6.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: [UPDATE]: Stocks.bm updated to perform currency conversions → [CURRENCY] perform currency conversions
Target Milestone: --- → Mozbot 2.6
(Assignee)

Comment 4

15 years ago
Checked in.

I checked it in as its own module (not part of Stocks) and removed the
"currencies" command since xe.com supports over 180 different currencies
(instead I added a link to their help page in the help).
(Assignee)

Updated

15 years ago
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
QA Contact: kerz → mozbot
Verified Fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.