sending SMTP SSL, TLS, and plain text fail on NAT'd IP address on our network

RESOLVED FIXED

Status

MailNews Core
Networking: SMTP
--
major
RESOLVED FIXED
14 years ago
9 years ago

People

(Reporter: Jeff Applewhite, Assigned: Christian Eyrich)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

when sending mail to smtp.duke.edu over TLS, SSL, and plain text in Mozilla 1.5
it worked - now on our network it is broken consistently for all machines that
are on a private NAT'd IP address.  We use a Nortel firewall based on the linux
kernel - but as I said 1.5 works fine.

Traces indicate that the Mozilla client seems to be asking for a SASL 	    
authentication mechanism (EXTERNAL) the server doesn't support.  Oddly, the
server's quite up front about it -- in the EHLO banner, it lists out the
authmechs it can support, but for some reason, Mozilla appears to be ignoring
the list and calling for the EXTERNAL SASL mechanism.

Reproducible: Always

Steps to Reproduce:
1. send mail to smtp.duke.edu on a private IP address - Mozilla 1.5 worked fine

Actual Results:  
send times out

Expected Results:  
sent mail!
(Reporter)

Updated

14 years ago
Summary: sending SMTP SSL, TLS, ans plain text fail on NAT'd IP address on our network → sending SMTP SSL, TLS, and plain text fail on NAT'd IP address on our network

Comment 1

14 years ago
Reporter, can you please attach a log to this bug ? You'll find the instructions
for it at <http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#smtp>.
Thanks !
(Reporter)

Comment 2

14 years ago
Created attachment 139661 [details]
logs from both Moz 1.5 and 1.6 for smtp problem
(Assignee)

Comment 3

14 years ago
Argh, what a bug.
Mozilla recognizes the EXTERNAL mechanism from the line
  "250-wilson.acpub.duke.edu Hello fw-external[...]"
Assignee: sspitzer → ch.ey
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 4

14 years ago
Created attachment 139666 [details] [diff] [review]
proposed patch

We searched the whol m_responseText for a known authentication mechanism. This
patch changes this to only search the current line responseLine (the line
starting with AUTH in case of authentication mechanisms).
(Assignee)

Updated

14 years ago
Attachment #139666 - Flags: review?(bienvenu)
(Reporter)

Comment 5

14 years ago
This Bug also seems to affect Firebird.  Will this patch be rolled into it as well?
(Reporter)

Comment 6

14 years ago
Thunderbird rather.
(Assignee)

Comment 7

14 years ago
Yes, this will help both clients.

Updated

14 years ago
Attachment #139666 - Flags: review?(bienvenu) → review+

Comment 8

14 years ago
fix checked in.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 9

14 years ago
*** Bug 247112 has been marked as a duplicate of this bug. ***
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.