When I navigate through this web site, I get frequent browser crashes.

RESOLVED INVALID

Status

Core Graveyard
Java: OJI
--
critical
RESOLVED INVALID
15 years ago
8 years ago

People

(Reporter: Craig Young, Assigned: Alfred Peng)

Tracking

({crash, stackwanted})

Trunk
x86
Windows XP
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040114
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040114

The Marriott web site crashes frequently using Mozilla. IE6 works fine, and does
not crash. Also, when crashes occur, there is never a popup window that states a
problem has been detected and offer to send a problem report.

Reproducible: Always

Steps to Reproduce:
1.Open the site http://www.marriott.com/incentives
2.Drill down through the menus to check out the Marriott properties
3.Crash

Actual Results:  
Mozilla crashes with no warning and no error message.

Expected Results:  
The site should have loaded and everything should have worked fine.

n/a

Comment 1

15 years ago
please mention more detailed steps to reproduce crash (which menu, etc.) or the
direct URL you crash on.
Keywords: crash, stackwanted
(Reporter)

Comment 2

15 years ago
Okay, here is how I reproduce it:

1.) Start at http://www.marriott.com/incentives
2.) Click on the "Browse Awards" section of the blue box.
3.) Select "See participating hotels listed by region and award"
4.) Select I on the alphabetical list.
5.) Select "Lincolnshire Marriott Resort" [You may crash here]
6.) Select "Theater" [It will likely crash here]

I hope this helps!

Comment 3

15 years ago
I don't get a crash, but I'm on MacOS X.  Clicking on those links, however,
generates the following in gdb:

load: class PanoApplet.class not found.
java.lang.ClassNotFoundException: java.io.IOException: open HTTP connection failed.
Reading symbols for shared libraries . done
        at sun.applet.AppletClassLoader.getBytes(AppletClassLoader.java:216)
        at sun.applet.AppletClassLoader.access$100(AppletClassLoader.java:37)
        at sun.applet.AppletClassLoader$1.run(AppletClassLoader.java:133)
        at java.security.AccessController.doPrivileged(Native Method)
        at sun.applet.AppletClassLoader.findClass(AppletClassLoader.java:130)
        at
sun.plugin.security.PluginClassLoader.findClass(PluginClassLoader.java:269)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:294)
        at sun.applet.AppletClassLoader.loadClass(AppletClassLoader.java:107)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:250)
        at sun.applet.AppletClassLoader.loadCode(AppletClassLoader.java:468)
        at sun.applet.AppletPanel.createApplet(AppletPanel.java:581)
        at sun.plugin.AppletViewer.createApplet(AppletViewer.java:1334)
        at sun.applet.AppletPanel.runLoader(AppletPanel.java:510)
        at sun.applet.AppletPanel.run(AppletPanel.java:288)
        at java.lang.Thread.run(Thread.java:491)
Reading symbols for shared libraries . done
Reading symbols for shared libraries . done
unable to open symbol file: CarbonLib: No such file or directory.
warning: Unable to read symbols from "CarbonLib".
warning: Unable to read symbols from "CarbonLib"; skipping.
Reading symbols for shared libraries + done
Reading symbols for shared libraries .+ done
Tried to create the VM in the Java Applet.plugin.
We detected that one already was created for this browser.
Using existing VM.
**Warning** this VM MAY not have the expected Java Runtime Parameters.
load: class PanoApplet.class not found.
java.lang.ClassNotFoundException: java.io.IOException: open HTTP connection failed.
        at sun.applet.AppletClassLoader.getBytes(AppletClassLoader.java:216)
        at sun.applet.AppletClassLoader.access$100(AppletClassLoader.java:37)
        at sun.applet.AppletClassLoader$1.run(AppletClassLoader.java:133)
        at java.security.AccessController.doPrivileged(Native Method)
        at sun.applet.AppletClassLoader.findClass(AppletClassLoader.java:130)
        at
sun.plugin.security.PluginClassLoader.findClass(PluginClassLoader.java:269)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:294)
        at sun.applet.AppletClassLoader.loadClass(AppletClassLoader.java:107)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:250)
        at sun.applet.AppletClassLoader.loadCode(AppletClassLoader.java:468)
        at sun.applet.AppletPanel.createApplet(AppletPanel.java:581)
        at sun.plugin.AppletViewer.createApplet(AppletViewer.java:1334)
        at sun.applet.AppletPanel.runLoader(AppletPanel.java:510)
        at sun.applet.AppletPanel.run(AppletPanel.java:288)
        at java.lang.Thread.run(Thread.java:491)
unable to open symbol file: CarbonLib: No such file or directory.
warning: Unable to read symbols from "CarbonLib".
warning: Unable to read symbols from "CarbonLib"; skipping.
Reading symbols for shared libraries . done
unable to open symbol file: CarbonLib: No such file or directory.
warning: Unable to read symbols from "CarbonLib".
warning: Unable to read symbols from "CarbonLib"; skipping.
Reading symbols for shared libraries ..+ done
Tried to create the VM in the Java Applet.plugin.
We detected that one already was created for this browser.
Using existing VM.
**Warning** this VM MAY not have the expected Java Runtime Parameters.
load: class PanoApplet.class not found.
java.lang.ClassNotFoundException: java.io.IOException: open HTTP connection failed.
        at sun.applet.AppletClassLoader.getBytes(AppletClassLoader.java:216)
        at sun.applet.AppletClassLoader.access$100(AppletClassLoader.java:37)
        at sun.applet.AppletClassLoader$1.run(AppletClassLoader.java:133)
        at java.security.AccessController.doPrivileged(Native Method)
        at sun.applet.AppletClassLoader.findClass(AppletClassLoader.java:130)
        at
sun.plugin.security.PluginClassLoader.findClass(PluginClassLoader.java:269)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:294)
        at sun.applet.AppletClassLoader.loadClass(AppletClassLoader.java:107)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:250)
        at sun.applet.AppletClassLoader.loadCode(AppletClassLoader.java:468)
        at sun.applet.AppletPanel.createApplet(AppletPanel.java:581)
        at sun.plugin.AppletViewer.createApplet(AppletViewer.java:1334)
        at sun.applet.AppletPanel.runLoader(AppletPanel.java:510)
        at sun.applet.AppletPanel.run(AppletPanel.java:288)
        at java.lang.Thread.run(Thread.java:491)
unable to open symbol file: CarbonLib: No such file or directory.
warning: Unable to read symbols from "CarbonLib".
warning: Unable to read symbols from "CarbonLib"; skipping.
Reading symbols for shared libraries .. done

So, it looks like you may be running into a Java problem.  What Java VM are you
using?

Comment 4

15 years ago
Thanks for the steps.
wfm (no crash) using Firebird 20030115 on Win2k + Sun's JRE 1.4.2_02.
However, the applet doesn't load and I see the same data as in comment 3 on the
Java console (probably a broken applet).

IE6 uses its own Java engine (unless you use Sun's JRE 1.4.x), which could
explain why it doesn't behave the same.
Can you upgrade to latest Sun's JRE 1.4.2_03 and try again ?
http://java.sun.com/j2se/1.4.2/download.html
Assignee: general → kyle.yuan
Component: Browser-General → Java: OJI
(Reporter)

Comment 5

15 years ago
Here is the Java info for my system currently:

Java Plug-in

    File name: NPJava11.dll
    Java Plug-in 1.4.1_02 for Netscape Navigator (DLL Helper)

MIME Type 	Description 	Suffixes 	Enabled
application/x-java-applet;version=1.1.1 	Java Applet 		Yes
application/x-java-bean;version=1.1.1 	JavaBeans 		Yes
application/x-java-applet;version=1.1 	Java Applet 		Yes
application/x-java-bean;version=1.1 	JavaBeans 		Yes
application/x-java-applet 	Java Applet 		Yes
application/x-java-bean 	JavaBeans 		Yes
Java Plug-in

    File name: NPJava12.dll
    Java Plug-in 1.4.1_02 for Netscape Navigator (DLL Helper)

MIME Type 	Description 	Suffixes 	Enabled
application/x-java-applet;version=1.2 	Java Applet 		Yes
application/x-java-bean;version=1.2 	JavaBeans 		Yes
application/x-java-applet;version=1.1.3 	Java Applet 		Yes
application/x-java-bean;version=1.1.3 	JavaBeans 		Yes
application/x-java-applet;version=1.1.2 	Java Applet 		Yes
application/x-java-bean;version=1.1.2 	JavaBeans 		Yes
Java Plug-in

    File name: NPJava13.dll
    Java Plug-in 1.4.1_02 for Netscape Navigator (DLL Helper)

MIME Type 	Description 	Suffixes 	Enabled
application/x-java-applet;version=1.3.1 	Java Applet 		Yes
application/x-java-bean;version=1.3.1 	JavaBeans 		Yes
application/x-java-applet;version=1.4 	Java Applet 		Yes
application/x-java-bean;version=1.4 	JavaBeans 		Yes
application/x-java-applet;version=1.4.1 	Java Applet 		Yes
application/x-java-bean;version=1.4.1 	JavaBeans 		Yes
Java Plug-in

    File name: NPJava32.dll
    Java Plug-in 1.4.1_02 for Netscape Navigator (DLL Helper)

MIME Type 	Description 	Suffixes 	Enabled
application/x-java-applet;version=1.3 	Java Applet 		Yes
application/x-java-bean;version=1.3 	JavaBeans 		Yes
application/x-java-applet;version=1.2.2 	Java Applet 		Yes
application/x-java-bean;version=1.2.2 	JavaBeans 		Yes
application/x-java-applet;version=1.2.1 	Java Applet 		Yes
application/x-java-bean;version=1.2.1 	JavaBeans 		Yes
Java Plug-in

    File name: NPJPI141_02.dll
    Java Plug-in 1.4.1_02 for Netscape Navigator (DLL Helper)

MIME Type 	Description 	Suffixes 	Enabled
application/x-java-applet;jpi-version=1.4.1_02 	Java Applet 		Yes
application/x-java-bean;jpi-version=1.4.1_02 	JavaBeans 		Yes
Java Plug-in

    File name: NPOJI610.dll
    Java Plug-in 1.4.1_02 for Netscape Navigator (DLL Helper)

MIME Type 	Description 	Suffixes 	Enabled
application/x-java-vm 	Java Virtual Machine for Netscape 6.x 		Yes


So, it appears that I am using an old version of the Java RTE. I will upgrade to
the latest version and retest.
(Reporter)

Comment 6

15 years ago
Okay, I upgraded to the recommended jre, and I am still getting the crashes.
They seem to be related to the browser loading the 360 virtual tour window
applet in the URL: http://marriott.com/property/propertyPage.mi?marshaCode=CHILN

Here is my current Java environment stuff:

Java Plug-in

    File name: NPJava11.dll
    Java Plug-in 1.4.2_03 for Netscape Navigator (DLL Helper)

MIME Type 	Description 	Suffixes 	Enabled
application/x-java-applet;version=1.1.1 	Java Applet 		Yes
application/x-java-bean;version=1.1.1 	JavaBeans 		Yes
application/x-java-applet;version=1.1 	Java Applet 		Yes
application/x-java-bean;version=1.1 	JavaBeans 		Yes
application/x-java-applet 	Java Applet 		Yes
application/x-java-bean 	JavaBeans 		Yes
Java Plug-in

    File name: NPJava12.dll
    Java Plug-in 1.4.2_03 for Netscape Navigator (DLL Helper)

MIME Type 	Description 	Suffixes 	Enabled
application/x-java-applet;version=1.2 	Java Applet 		Yes
application/x-java-bean;version=1.2 	JavaBeans 		Yes
application/x-java-applet;version=1.1.3 	Java Applet 		Yes
application/x-java-bean;version=1.1.3 	JavaBeans 		Yes
application/x-java-applet;version=1.1.2 	Java Applet 		Yes
application/x-java-bean;version=1.1.2 	JavaBeans 		Yes
Java Plug-in

    File name: NPJava13.dll
    Java Plug-in 1.4.2_03 for Netscape Navigator (DLL Helper)

MIME Type 	Description 	Suffixes 	Enabled
application/x-java-applet;version=1.3.1 	Java Applet 		Yes
application/x-java-bean;version=1.3.1 	JavaBeans 		Yes
application/x-java-applet;version=1.4 	Java Applet 		Yes
application/x-java-bean;version=1.4 	JavaBeans 		Yes
application/x-java-applet;version=1.4.1 	Java Applet 		Yes
application/x-java-bean;version=1.4.1 	JavaBeans 		Yes
Java Plug-in

    File name: NPJava14.dll
    Java Plug-in 1.4.2_03 for Netscape Navigator (DLL Helper)

MIME Type 	Description 	Suffixes 	Enabled
application/x-java-applet;version=1.4.2 	Java Applet 		Yes
application/x-java-bean;version=1.4.2 	JavaBeans 		Yes
Java Plug-in

    File name: NPJava32.dll
    Java Plug-in 1.4.2_03 for Netscape Navigator (DLL Helper)

MIME Type 	Description 	Suffixes 	Enabled
application/x-java-applet;version=1.3 	Java Applet 		Yes
application/x-java-bean;version=1.3 	JavaBeans 		Yes
application/x-java-applet;version=1.2.2 	Java Applet 		Yes
application/x-java-bean;version=1.2.2 	JavaBeans 		Yes
application/x-java-applet;version=1.2.1 	Java Applet 		Yes
application/x-java-bean;version=1.2.1 	JavaBeans 		Yes
Java Plug-in

    File name: NPJPI142_03.dll
    Java Plug-in 1.4.2_03 for Netscape Navigator (DLL Helper)

MIME Type 	Description 	Suffixes 	Enabled
application/x-java-applet;jpi-version=1.4.2_03 	Java Applet 		Yes
application/x-java-bean;jpi-version=1.4.2_03 	JavaBeans 		Yes
Java Plug-in

    File name: NPOJI610.dll
    Java Plug-in 1.4.2_03 for Netscape Navigator (DLL Helper)

MIME Type 	Description 	Suffixes 	Enabled
application/x-java-vm 	Java Virtual Machine for Netscape 		Yes

Comment 7

15 years ago
do you crash with a fresh profile "mozilla -profilemanager" ?
Do you possibly have other plug-ins interfering ?

Do you see any error message from Mozilla or in the Java Console (right click on
the Java icon when it's in the systray) ?
(Reporter)

Comment 8

15 years ago
do you crash with a fresh profile "mozilla -profilemanager" ?

I set up a new profile, and it made no difference. Still crashed.

Do you possibly have other plug-ins interfering ? 

I am not sure how I would be able to tell that. Can you be more specific? I do
have a few other plug-ins installed, but not very many.

Do you see any error message from Mozilla or in the Java Console (right click on
the Java icon when it's in the systray) ?

I had a tough time getting a trap of this, but here is the log I get:

Java(TM) Plug-in: Version 1.4.2_03
Using JRE version 1.4.2_03 Java HotSpot(TM) Client VM
User home directory = C:\Documents and Settings\young
Proxy Configuration: Browser Proxy Configuration


----------------------------------------------------
c:   clear console window
f:   finalize objects on finalization queue
g:   garbage collect
h:   display this help message
l:   dump classloader list
m:   print memory usage
o:   trigger logging
p:   reload proxy configuration
q:   hide console
r:   reload policy configuration
s:   dump system properties
t:   dump thread list
v:   dump thread stack
x:   clear classloader cache
0-5: set trace level to <n>
----------------------------------------------------
Trace level set to 5: basic, net, security, ext, liveconnect ... completed.
Trace level set to 0: none ... completed.
Trace level set to 4: basic, net, security, ext ... completed.
Trace level set to 3: basic, net, security ... completed.
Trace level set to 2: basic, net ... completed.
Trace level set to 5: basic, net, security, ext, liveconnect ... completed.
Garbage collect ... completed.
Memory: 1,984K  Free: 1,466K  (73%) ... completed.
Registered modality listener
Referencing classloader: sun.plugin.ClassLoaderInfo@16c163f, refcount=1
Loading applet ...
Initializing applet ...
Starting applet ...
Connecting http://marriott.com/EPP/PANOIMAGES/HOME_IMAGE4_CHILN.JPG with no proxy
Connecting http://marriott.com/EPP/PANOIMAGES/HOME_IMAGE4_CHILN.JPG with cookie
"VSC=3FFA1CAE1AB96AEF; JSESSIONID=00001yWS15WyeBADRlNkHCy0y29:v58mh4ks"
Connecting http://marriott.com/EPP/PanoApplet.jar with no proxy
Loading http://marriott.com/EPP/PANOIMAGES/HOME_IMAGE4_CHILN.JPG from cache
Connecting http://marriott.com/EPP/PanoApplet.jar with cookie
"VSC=3FFA1CAE1AB96AEF; JSESSIONID=00001yWS15WyeBADRlNkHCy0y29:v58mh4ks"
Connecting http://marriott.com/EPP/PanoApplet.class with no proxy
Connecting http://marriott.com/EPP/PanoApplet.class with cookie
"VSC=3FFA1CAE1AB96AEF; JSESSIONID=00001yWS15WyeBADRlNkHCy0y29:v58mh4ks"
Connecting http://marriott.com/EPP/PanoApplet/class.class with no proxy
Connecting http://marriott.com/EPP/PanoApplet/class.class with cookie
"VSC=3FFA1CAE1AB96AEF; JSESSIONID=00001yWS15WyeBADRlNkHCy0y29:v58mh4ks"
load: class PanoApplet.class not found.
java.lang.ClassNotFoundException: PanoApplet.class
	at sun.applet.AppletClassLoader.findClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at sun.applet.AppletClassLoader.loadClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at sun.applet.AppletClassLoader.loadCode(Unknown Source)
	at sun.applet.AppletPanel.createApplet(Unknown Source)

The crash occured at this point.

Now, I did try uninstalling Java. With Java uninstalled, I do not get the crash.
Of course, the Java applet at that URL does not load, and you see the typical
get the plugin type of display in the window the Java screen would appear in. I
reinstalled Java, and get the crashes once again. On this system, they are very
consistent.

Comment 9

15 years ago
wfm on Win2k, looks like a WinXP specific bug. Craig, are you sure your IE use
the same jre (1.4.2_03) as mozilla does? I remember that MS stops shipping JVM
in XP.
(Reporter)

Comment 10

15 years ago
Created attachment 139464 [details]
Shot of my desktop showing IE settings.

Comment 11

15 years ago
I get an Error 404: /incentives/error.jsp when trying to follow step 3 in comment 2

Comment 12

14 years ago
do you still crash with Mozilla 1.7rc2 ? If so, please post Talkback Incident ID
for this crash by running "mozilla\components\talkback.exe"

Updated

13 years ago
Assignee: yuanyi21 → pete.zha

Comment 13

13 years ago
mass reassign to Alfred
Assignee: zhayupeng → alfred.peng
wfm on Firefox 2.0a1 from 20060502

Comment 15

12 years ago
Craig, if you still have this problem please reopen the bug and provide a new set of steps. The steps in comment 2 are no longer valid AFAICT.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.