Last Comment Bug 231189 - No copy-paste-etc... context menu on <ISINDEX> form field
: No copy-paste-etc... context menu on <ISINDEX> form field
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XUL (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://www.mail-abuse.org/cgi-bin/lookup
Depends on: 326369
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-16 14:57 PST by Matteo
Modified: 2011-08-07 12:54 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Matteo 2004-01-16 14:57:42 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031216 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031216 Firebird/0.7+

In the page at http://www.mail-abuse.org/cgi-bin/lookup, right click into the
field beside "Enter search keywords:" doesn't get the cut/paste context menu,
but the menu Back-Reload-etc...

Reproducible: Always

Steps to Reproduce:
1.Open http://www.mail-abuse.org/cgi-bin/lookup
2.Right click into the form field in the page
3.

Actual Results:  
The menu Back-Reload-etc... appears

Expected Results:  
The menu Copy-Cut-etc... should appear
Comment 1 Jo Hermans 2004-01-16 15:33:04 PST
Confirmed in build 2004011605 on Mac OS X 10.2.8

It's because it's an <ISINDEX> field, nor a regular <INPUT>. Note that it's
deprecated in HTML 4 and hardly used anymore, so I don't know if anybody will
bother to fix it. 
Comment 2 Jonas Sicking (:sicking) 2011-08-07 12:54:47 PDT
This should be fixed now that <isindex> uses normal <input> fields.

Note You need to log in before you can comment on or make changes to this bug.