non-subscribable folders in subscribe ui should *not* be grayed out

RESOLVED WONTFIX

Status

SeaMonkey
MailNews: Message Display
RESOLVED WONTFIX
14 years ago
7 years ago

People

(Reporter: mcsmurf, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
In the window to subscribe to newsgroups, the text of the newsgroups tree is
displayed cursive and in disabled color. This confused me, because i thought i
couldn't click this on now anymore (but it worked luckily :). When you expand
the tree and get to a newsgroup, the newsgroup is displayed in normal text, for
example:
de (cursive&disabled color)
|--de.comm (cursive&disabled color)
      |--de.comm.software (cursive&disabled color)
                |--de.comm.software.mozilla (cursive&disabled color)
                             |--de.comm.software.mozilla.browser (normal text)
David, could this fallout from the IMAP/subscribe folder changes?

Comment 2

14 years ago
By design, as per bug 229214.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID

Comment 3

14 years ago
Neil, I don't agree. Even though "grayed out" is part of bug bug 229214's
summary, it's actually about enhancing the visual difference between
subscribable folders and non-subscribable ones.

Especially with certain theme designs (like Modern), a grayed-out twisty is hard
to distinguish from an non-grayed-out.

So I think that making non-subscribable folders shown in italics and not having
them a subscribe icon should suffice.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Summary: Parent text of tree when subscribing to a newsgroup is cursive and disabled → non-subscribable folders in subscribe ui should *not* be grayed out
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: sspitzer → mail
Status: REOPENED → NEW
Assignee: mail → nobody
QA Contact: esther → message-display

Comment 4

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 5

8 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago8 years ago
Resolution: --- → EXPIRED

Comment 6

7 years ago
Non-expandable twigs wouldn't have a twisty in the first place.
With six years to think about, I'd say WONTFIX.
Resolution: EXPIRED → WONTFIX
You need to log in before you can comment on or make changes to this bug.