Displays flight search results and advertisements inconsistantly (wrong display & location)

RESOLVED DUPLICATE of bug 193984

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 193984
14 years ago
14 years ago

People

(Reporter: Eric Anderson, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

Mozilla doesn't appear to render Travelocity.com flight option pages
consistently correctly.  At the URL www.travelocity.com/flights, the ads and
other items that should be displayed on the right side of the page will often
start out at the bottom of the page.  When the problem occurs, reloading the
page will sometimes resolve it.

Also, if you enter cities (From and To) AND select "search a date range", the
calendar display (that you pick your flight dates from) will be too wide -
sometimes wrapping to subsequent lines - or too narrow or wrap in the middle of
the page or overlap other text.  After you've picked a date choice, the display
of the available flights will sometimes list one or two results up top, then
skip several lines and list the rest of the choices at the bottom after all the ads.

Again, refreshing will sometimes fix the problems - and sometimes not.  If you
can refresh and the layout changes, it's had the problem.

I run Mozilla on three quite different computers.  This occurs on all of them, 
 and has been happening since at least Mozilla 1.0.

Reproducible: Sometimes

Steps to Reproduce:
These steps don't always have the problem, but it's regular - 50% of the time.
1. At the URL, first of all you should see a square boxed ad on the far right
about halfway down the page.

2. In the "Find the best airfare" area on the left, pick a roundtrip flight. 
Some examples are "From:" as "san" and "To:" as "den" or "nyc". It seems to
happen with all cities.  Then for "3 When do you prefer to travel?" pick "search
a date range."  I usually accept the default choice here.  Then I leave question
4 and 5 at their default choices and click on the "Search Now" button.

3. On the page that follows you should get tabs across the top, ads and other
info on the left and flights to the right of the ads.  The listing of flights
should remain consistent down the page - even past the ads.

4.Select a flight and you should be taken to the following page where you select
 departure and return dates from up to 3 displayed months calendars where the
selected flight is available at that price.

5. On the following page you select acceptable flight times for the dates you
have selected.
Actual Results:  
Item 1. The square ad's doesn't show or is listed at the bottom of the page.

Item 2. No problems here.

Item 3. All the flights aren't listed, or will wrap to subsequent lines, or only
a couple of flights will show to the right, the rest will be down below.  The
flights listed below the ads are not in a line with the flights below.

Item 4. The calendars are too wide or too narrow or wrap in the middle.

Item 5. Same symptoms as number 3.

Expected Results:  
Item 1. You should see a square boxed ad on the far right about halfway down the
page.

Item 2. no problems here.

Item 3.  You should get tabs across the top, ads and other info on the left and
flights to the right of the ads.  The listing of flights should remain
consistent down the page - even past the ads.

Item 4. Up to 3 small calendars should display side by side where you can pick
dates to depart and return.

Item 5. Same results as number 3. 

Many times on having the problems I've jumped into IE where I've never
experienced it.

Comment 1

14 years ago
dupe of a WFM bug -- "Mozilla and Travelocity do not play well together."

I'll reopen it.

*** This bug has been marked as a duplicate of 193984 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.