Just installed 1.6 Cannot change themes now in browser .

RESOLVED WORKSFORME

Status

SeaMonkey
Themes
RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: Dick Woods, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

Highlight classic or modern , either one . Will not change now. Did with 1.5

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

14 years ago
Can confirm with 20040117 on Linux and 20040119 on Win98.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All

Comment 2

14 years ago
can confirm for win 2k

Comment 3

14 years ago
WFM in both prefs menu, and view menu using the 1.6 sea release on Win XP. Of
course, you need to *restart Mozilla*, but that's nothing new. How about some
more details from the folks who /are/ experiencing this?
Where in the UI are you changing themes?
Do you have quick launch enabled? (I don't)
Have you restarted Mozilla?
Was the browser the only component loaded?
Do you have any extensions installed that might affect this?

Comment 4

14 years ago
Oh, it indeed makes a difference where I'm switching the theme, but not if
Quickstart is enabled or not. 

View/Apply Theme works, Preferences/Appearance/Themes doesn't work. Restart is
always done.

Comment 5

14 years ago
As I said, "WFM in both prefs menu, and view menu using the 1.6 sea release on
Win XP."
Did you try reinstalling the theme you want to switch to?

Comment 6

14 years ago
BTW, I didn't write about 1.6 but 1.7a (as you can see from the build dates),
but since the symptom is the same I think it's the same bug.

I only use classic and modern, so I don't think it's a buggy theme. Can still
see this with 20040112909 on Win98.
When switching from the Preferences I don't get the alert saying I've to restart
(but I do of course).

Comment 7

14 years ago
What about extensions?

Comment 8

14 years ago
None. And if you might come up to test with a fresh profile, I already done this
too.

Comment 9

14 years ago
Here's another question for those experiencing Bug 231302:
Did you install over the previous version?
(Win32 users)Did you choose the option to completely erase the mozilla.org folder?

Comment 10

14 years ago
(In reply to comment #9)
> Here's another question for those experiencing Bug 231302:
> Did you install over the previous version?
> (Win32 users)Did you choose the option to completely erase the mozilla.org folder?
This bug has manifested itself on a completely clean install of 1.6 final under
XP and with different profiles on the same installation.  No extensions except
English UK language pack.  This started happening "straight out of the box".  I
now have it happening on one of the profiles on a different install under
Win98SE which was an upgrade from 1.5.  This has extensions - prefbar.xpi and
English UK language pack.  I have experienced this with modern, classic,
toyfactory and other themes.  No I didn't erase the mozilla.org folder (didn't
have one on the new install) and the bug only just started becoming apparent on
my upgrade - I had been switching themes okay on at least one of the profiles,
but maybe not the one I'm having the problem with.  I did restart!
  
Are you folks still experiencing this?
Have any of you tested this in the 1.7 branch?

Comment 12

14 years ago
Oh, just tested with my installed 20040401-trunk and no problem anymore. So I
guess it's also gone for 1.7 branches.
How about others who have commented? Martin Tibensky? Richard Turner? The
reporter, Dick Woods?
Still experiencing it? Tested in 1.7 branch?

Comment 14

14 years ago
I have the same problems in the 1.7 trunk:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040514

Installation:
1. Unpacked Mozilla
2. Copied plugins
3. Kept the old profile.

Started. Can't change any theme.

Comment 15

14 years ago
For me I have found the solution. I have compared my "prefs.js" to a old backup
one. In the new one there were following lines which I deleted and now I can
switch themes again. (contenido is a cms, nautilus is my host)

user_pref("capability.principal.codebase.p0.granted", "UniversalXPConnect");
user_pref("capability.principal.codebase.p0.id", "http://contenido.nautilus");
user_pref("capability.principal.codebase.p1.granted", "UniversalXPConnect");
user_pref("capability.principal.codebase.p1.id", "http://contenido.nautilus");
user_pref("capability.principal.codebase.p10.granted", "UniversalXPConnect");
user_pref("capability.principal.codebase.p10.id", "http://contenido.nautilus");
user_pref("capability.principal.codebase.p11.granted", "UniversalXPConnect");
user_pref("capability.principal.codebase.p11.id", "http://contenido.nautilus");
user_pref("capability.principal.codebase.p12.granted", "UniversalXPConnect");
user_pref("capability.principal.codebase.p12.id", "file://");
user_pref("capability.principal.codebase.p2.granted", "UniversalXPConnect");
user_pref("capability.principal.codebase.p2.id", "http://contenido.nautilus");
user_pref("capability.principal.codebase.p3.granted", "UniversalXPConnect");
user_pref("capability.principal.codebase.p3.id", "http://contenido.nautilus");
user_pref("capability.principal.codebase.p4.granted", "UniversalXPConnect");
user_pref("capability.principal.codebase.p4.id", "http://contenido.nautilus");
user_pref("capability.principal.codebase.p5.granted", "UniversalXPConnect");
user_pref("capability.principal.codebase.p5.id", "http://contenido.nautilus");
user_pref("capability.principal.codebase.p6.granted", "UniversalXPConnect");
user_pref("capability.principal.codebase.p6.id", "http://contenido.nautilus");
user_pref("capability.principal.codebase.p7.granted", "UniversalXPConnect");
user_pref("capability.principal.codebase.p7.id", "http://contenido.nautilus");
user_pref("capability.principal.codebase.p8.granted", "UniversalXPConnect");
user_pref("capability.principal.codebase.p8.id", "http://contenido.nautilus");
user_pref("capability.principal.codebase.p9.granted", "UniversalXPConnect");
user_pref("capability.principal.codebase.p9.id", "http://contenido.nautilus");

Comment 16

14 years ago
I added the following reply to the wrong bug (135638) by mistake, although I'm
not really sure whether it fits best here or there. Note that I am running WinXP
and that I didn't see any "capability" lines in my prefs.js. I am changing my
theme through Edit->Preferences...->Appearance->Themes and choosing modern.

I'm not sure if this is related, but in both 1.7rc2 and 1.7rc3 I have been
unable to get my change to the modern theme to stick. However, it *does* change
the theme for exactly one mozilla restart. So I have to change my theme to
modern every other time I run mozilla. This behavior first appeared when I
installed 1.7rc2. I always uninstall the prior version of mozilla when
installing the new one, and one thing I did differently during the install of
1.7rc2 was to delete the entire mozilla.org folder when prompted to do so by the
uninstaller I launched through "add/remove programs". I did not delete the
entire folder when prompted during the uninstall prior to installing 1.7rc3 and
this strange behavior still seems to be there.

Comment 17

11 years ago
This bug should probably be closed, unless there's still an issue with Seamonkey 1.1.x.
Resolving as WFM.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.