crash if displaying a lot of non-printable characters

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: Joe, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031018 Firebird/0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031018 Firebird/0.7

When viewing a page with a lot of non-printable ascii characters, with several
lines, and scrolling through the file, firebird will almost always crash when
trying to display the characters too quickly.  ie: if there are a lot of them in
one area of the page, and you scroll past it too quickly, or if there are just a
lot of them in one displayed portion of the page, Firebird just crashes.  

Reproducible: Always

Steps to Reproduce:
1. Simply view a URL with a lot of nonprintable characters, (\x01, \x03, etc),
possibly only when having the scroll through them (ie: a long file containing a
lot of those types of characters).
Actual Results:  
Crash

Expected Results:  
Display the file, replacing said nonprintable characters with the generic box,
showing the ascii value.

Comment 1

14 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040114
Firebird/0.7+.

Comment 2

14 years ago
I had the same error when viewing this page:
http://www.pateam.org/archive/logs/dmesg_D220.txt

If you scroll down too fast, Mozilla Firebird crashes.

(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031018 Firebird/0.7
> Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031018 Firebird/0.7
> 
> When viewing a page with a lot of non-printable ascii characters, with several
> lines, and scrolling through the file, firebird will almost always crash when
> trying to display the characters too quickly.  ie: if there are a lot of them in
> one area of the page, and you scroll past it too quickly, or if there are just a
> lot of them in one displayed portion of the page, Firebird just crashes.  
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1. Simply view a URL with a lot of nonprintable characters, (\x01, \x03, etc),
> possibly only when having the scroll through them (ie: a long file containing a
> lot of those types of characters).
> Actual Results:  
> Crash
> 
> Expected Results:  
> Display the file, replacing said nonprintable characters with the generic box,
> showing the ascii value.

Comment 3

14 years ago
Reporters URL doesn't work anymore, tried the URL in comment #2, no problems.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040207 Firefox/0.8
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113

Comment 4

14 years ago
comment #2 url also WFM: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b)
Gecko/20040329 Firefox/0.8.0+
(Reporter)

Comment 5

14 years ago
Just tested it again:  Comment #2's URL does crash Firebird (Mozilla/5.0 (X11;
U; Linux i686; en-US; rv:1.5) Gecko/20040219 Firebird/0.7) when scrolling down.
 At about halfway down the page, it hangs for about 1-2 seconds as if it's
lagging, then all Firebird processes just die.  (gentoo linux, fwiw)
(Reporter)

Comment 6

14 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040401 Firefox/0.8

The problem does not occur in this build of Firefox, so I can only assume that
whatever bug it was, has since been fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 7

14 years ago
"FIXED" means we did something in this bug to fix it. We didn't. Marking 
WORKSFORME.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Updated

14 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.