About:about lists new/errorneous about: commands that the user typed

RESOLVED DUPLICATE of bug 230776

Status

RESOLVED DUPLICATE of bug 230776
15 years ago
14 years ago

People

(Reporter: jose_darwin, Unassigned)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113

The about:about feature lists all the about:xxx commands that the user typed.
For example, if I typed about:abc into the browser, the next time I run
about:about, it will list about:abc as one of the valid about: commands. 

The new entry disappears once the browser is restarted.

Reproducible: Always

Steps to Reproduce:
1. Type about:abc into the browser and press enter
2. Type about:about into the browser and press enter


Actual Results:  
about:abc will be listed as one of the valid about: commands although it is not
valid

Expected Results:  
List only valid about: commands instead of including what they users have
previously typed.

about:buildconfig

Build platform
target
i686-pc-linux-gnu

Build tools
Compiler 	Version 	Compiler flags
gcc 	gcc version 3.2.3 	-Wall -W -Wno-unused -Wpointer-arith -Wcast-align
-Wno-long-long -pedantic -pthread -pipe
c++ 	gcc version 3.2.3 	-fno-rtti -fno-exceptions -Wall -Wconversion
-Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy
-Wno-long-long -pedantic -fshort-wchar -pthread -pipe -I/usr/X11R6/include

Configure arguments
--disable-tests --enable-extensions=default,irc --without-system-nspr
--without-system-jpeg --without-system-zlib --without-system-png
--without-system-mng --disable-debug '--enable-optimize=-O2 -g' --enable-crypto

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 230776 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.