I add an Obfuscated (obscured) link in <HTML> Source. I click on Normal then back to <HTML> Source and my link is unobfuscated.

RESOLVED DUPLICATE of bug 174216

Status

SeaMonkey
Composer
RESOLVED DUPLICATE of bug 174216
15 years ago
14 years ago

People

(Reporter: Robert W., Unassigned)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040113

I want to have an "e-mail me" link, but I don't want spyders to have easy access
to my e-mail address. So, instead of "<a href="mailto:me@foo.com">e-mail me</a>
I try to add the link in <HTML> Source this way:

   <a
href="mailto:&#109;&#101;&#64;&#102;&#111;&#111;&#46;&#99;&#111;&#109;">e-mail
me</a>

Then I click to Normal and back to <HTML> Source and the text I have entered is
converted back to "<a href="mailto:me@foo.com">e-mail me</a>". I have the
"Retain Original Source Formatting" button selected, even though this happens
*before* I save.

Reproducible: Always

Steps to Reproduce:
1. Click on the <HTML> Source tab.
2. Add an obfuscated link.
3. Click on the Nrmal tab.
4. Click on the <HTML> Source tab

Actual Results:  
The obfuscated link returns to unobfuscated

Expected Results:  
Left the HTML code I entered alone.

I can see that sometime, some people might want this behavior, but there should
be an option like the "Retain Original Source Formatting" button that turns off
this behavior.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 174216 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.