Downloading message body does not work with cyrus imapd

RESOLVED FIXED

Status

MailNews Core
Networking: IMAP
--
major
RESOLVED FIXED
14 years ago
9 years ago

People

(Reporter: Fabian Seitz, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

20.98 KB, application/x-javascript
Details
26.40 KB, application/octet-stream
Details
(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

I just upgraded from 1.5 to 1.6. Now the problem appears that when I'm clicking
on a message of one of my Cyrus IMAPD accounts, the mouse pointer changes to the
hour glass, but nothing happens (only sometimes "Loading Message..." is shown).
Messages that have been downloaded before this upgrade are shown as usual. The
Read/Unread status of the mail remains unchanged. Changing this status is
possibly by clicking on the green dot. My other IMAP accounts work well.

Reproducible: Always

Steps to Reproduce:
1. Try to download a new message
2.
3.

Actual Results:  
Mouse pointer becomes a hour glass, sometimes "Loading Message..." is shown.
Read/Unread status remains unchanged.

Expected Results:  
The message should be downloaded and displayed.

I had the same problem with Mozilla 1.6 beta and decided to downgrade again.
Mozilla 1.5 works well. I didn't test 1.6 alpha.

Comment 1

14 years ago
Reporter, please attach an IMAP protocol log; see 
http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap
(Assignee)

Comment 2

14 years ago
Also, Fabian, have you set your online directory in your mozilla advanced imap
server settings to anything, like INBOX., or something like that? Or have you
changed your personal namespace? e-mailing me your prefs.js might be helpful. thx.
(Reporter)

Comment 3

14 years ago
Created attachment 139430 [details]
my current prefs.js
(Reporter)

Comment 4

14 years ago
Created attachment 139432 [details]
The IMAP logfile

This is the IMAP logfile of my last session. I opened MailNews and clicked on
the inbox. dingmail.dasding.de is the server with this problem.
(Reporter)

Comment 5

14 years ago
Thanks for the fast answers. I attached the prefs.js and the IMAP logfile.
I discovered that not only downloading the message body fails. It is also not
possible to download new messages. It looks like the whole Inbox hangs and I can
only see the status before the upgrade.
My IMAP Server Directory is not set. The personal namespace is "INBOX."
(Assignee)

Comment 6

14 years ago
Unfortunately, your log has a bunch of nulls in it where the interesting data
would be. I don't know what causes that but other people have had that problem.
Can you tell if you're even logging onto the server successfully? Do you have
your password stored in the password manager? Without being able to see the log,
I'm just guessing here, but it's possible that your server is one of those
servers that advertise cram-md5 support, but drop the connection when it's used
- I fixed our handling of that last night...Could you try today's Mozilla 1.7
nightly build and see if it works for you? You might also try generating a log
again and see if you get more non-null data in it...
(Reporter)

Comment 7

14 years ago
I tried the nightly build and it works. Obviously it's the cram-md5 problem (I
posted bug 208026 in last June and thought it was already fixed).
Do you need some more information or is the problem solved for you now? I could
check the server logs if you want to.
(Assignee)

Comment 8

14 years ago
yes, there was a regression in the cram-md5 code - someone made a patch which
turned it back on by default (which I reviewed, my bad). If the nightly build
works, then I'll just mark this fixed. If there's a 1.6.1 or something, I'll try
to get that fix in.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

14 years ago
Thank you very much!
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.