[DOGFOOD][BLOCKER] unable to view messages for IMAP & POP

VERIFIED FIXED

Status

defect
P3
blocker
VERIFIED FIXED
20 years ago
15 years ago

People

(Reporter: sspitzer, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

on today's build (1-5-2000) on all three platforms, we are unable to load
messages into the message pane.  (news, local, and I believe imap.)
Severity: normal → blocker
Hardware: PC → All
how are you able to get passed the password problem? using the workaround pmock
posted in that bug?
I'm able to get passed the password problem because my password is saved in my
prefs.js file.
adding mscott, jefft, and bienvenu to the cc list.
I'm not having any trouble reading messages, but I'm running with mscott's
patches.
I am seeing this in the console:

DocLoaderFactory: Unable to create ContentViewer for command=view,
content-type=text/xul

probably the reason we are not seeing output.

- rhp
if you are running with mscott's "super-fast" message display patches, then your
vote doesn't count.

this seems to affecting the nightly build and the tip builds.
anyone have any ideas on this?  linux build 2000-01-05-12-M13 just finished and
fixes the mail pw problem, so now I'm seeing this one.
That's strange, I still cannot see the IMAP messages display on the message
body.
I used 2000-01-05-12-M13 Linux commercial build.
I was referring to 23132, this bug is still live.  I've talked to don and he's
trying to track someone down for this since this is the only blocker keeping the
tree closed (that I'm aware of).
This problem is not specific for IMAP.
It occurred on POP for Linux 2000-01-05-12-M13 commercial build, too.
Summary: [BLOCKER] unable to view messages → [DOGFOOD][BLOCKER] unable to view messages for IMAP & POP
Updating summary for adding IMAP & POP. Nominating [DOGFOOD].
For imap messages we failed with the following stack:

nsImapMockChannel::GetOwner() returns NS_ERROR_NOT_IMPLEMENTED. mscott, any
ideas?

nsImapMockChannel::GetOwner(nsImapMockChannel * const 0x037896c0, nsISupports *
* 0x0012f8a8) line 6410
nsXULDocument::PrepareToLoad(nsISupports * 0x03051ad0, const char * 0x03791a50,
nsIChannel * 0x037896c0, nsILoadGroup * 0x03054d10, nsIParser * * 0x0012f914)
line 4023 + 36 bytes
nsXULDocument::StartDocumentLoad(nsXULDocument * const 0x03791220, const char *
0x03791a50, nsIChannel * 0x037896c0, nsILoadGroup * 0x03054d10, nsISupports *
0x03051ad0, nsIStreamListener * * 0x0012fd30) line 722 + 48 bytes
nsLayoutDLF::CreateRDFDocument(const char * 0x03791a50, nsIChannel * 0x037896c0,
nsILoadGroup * 0x03054d10, const char * 0x0012fcf0, nsISupports * 0x03051ad0,
nsISupports * 0x00000000, nsIStreamListener * * 0x0012fd30, nsIContentViewer * *
0x0012fc10) line 455 + 43 bytes
nsLayoutDLF::CreateInstance(nsLayoutDLF * const 0x037918c0, const char *
0x03791a50, nsIChannel * 0x037896c0, nsILoadGroup * 0x03054d10, const char *
0x0012fcf0, nsISupports * 0x03051ad0, nsISupports * 0x00000000,
nsIStreamListener * * 0x0012fd30, nsIContentViewer * * 0x0012fc10) line 269 + 40
bytes
nsWebShell::CreateViewer(nsIChannel * 0x037896c0, const char * 0x0012fcf0, const
char * 0x03791a50, nsIStreamListener * * 0x0012fd30) line 1782 + 95 bytes
nsWebShell::DoContent(nsWebShell * const 0x03051aec, const char * 0x0012fcf0,
int 0, const char * 0x100782d0 gCommonEmptyBuffer, nsIChannel * 0x037896c0,
nsIStreamListener * * 0x0012fd30, int * 0x0012fcd4) line 1735 + 36 bytes
nsDocumentOpenInfo::DispatchContent(nsIChannel * 0x037896c0, nsISupports *
0x00000000) line 335 + 109 bytes
nsDocumentOpenInfo::OnStartRequest(nsDocumentOpenInfo * const 0x0378f870,
nsIChannel * 0x037896c0, nsISupports * 0x00000000) line 219 + 16 bytes
nsOnStartRequestEvent::HandleEvent(nsOnStartRequestEvent * const 0x03795d10)
line 199
nsStreamListenerEvent::HandlePLEvent(PLEvent * 0x03794400) line 93 + 12 bytes
PL_HandleEvent(PLEvent * 0x03794400) line 522 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x0108ae70) line 483 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x00240690, unsigned int 49445, unsigned int 0,
long 17346160) line 951 + 9 bytes
USER32! 77e7124c()
0108ae70()
Assignee: phil → mscott
yeah waterson and I just checked in the fixes.

repull nsImapProtocol.cpp and nsMsgProtocol.cpp
*** Bug 23176 has been marked as a duplicate of this bug. ***
my seamonkey build won't let me mark this bug as fixed! Can someone please do
that for me? =)
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
marking fixed for scott.
Does it fix on POP and News as well since problem also happened on those
servers.
Yes it does.
OK. Great!!
this appears to be fixed in the latest linux builds.  respinning mac and windows
now.
Linux Redhat 6.0 (2000-01-05-15 M13)
I try it on this build, I can view message both in POP and IMAP now.

Waiting for Mac and Win_nt builds to come out.
Status: RESOLVED → VERIFIED
QA Contact: lchiang → pmock
Verified as fixed on win, mac, and linux using the following builds:
ftp://sweetlou/products/client/seamonkey/windows/32bit/x86/2000-01-05-16-M13/sea
monkey32e.exe
ftp://sweetlou/products/client/seamonkey/unix/linux_glibc/2.2/x86/2000-01-05-15-
M13/netscape-i686-pc-linux-gnu.tar.gz
ftp://sweetlou/products/client/seamonkey/macos/8.x/ppc/2000-01-05-15-M13/NSMacIn
staller-M13.sea.bin

I can view messages under pop, imap, and news.  Great work Mscott. :)
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.