Drop-down javascript menu doesn't work

RESOLVED INVALID

Status

RESOLVED INVALID
15 years ago
14 years ago

People

(Reporter: andrewtracey, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

36.08 KB, application/x-javascript
Details
(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

There is a drop-down Javascript menu at the top of this page which fails to work
in Mozilla 1.6. Page works fine in Mozilla 1.5.1, IE and Safari.

It may well be that this is due to badly implemented Javascript, which Mozilla
is only now refusing to interpret correctly. I've had a look through the release
notes for this version but can't find anything which might suggest the cause.

Reproducible: Always

Steps to Reproduce:
1. Load page
2.
3.

Actual Results:  
Menu does not appear at all

Comment 1

15 years ago
it works fine with 1.6 in wXP.
Could you please try with a new profile?
(Reporter)

Comment 2

15 years ago
Must be a profile thing - created new profile and page loads OK.
Please try to figure out what in your profile causes this (or at least attach
your prefs.js to this bug).
(Reporter)

Comment 4

15 years ago
Created attachment 139418 [details]
Prefs.js 

This is my prefs.js file

Comment 5

15 years ago
With his prefs.js, I cannot get the menu to work.

The whole row of [ ILEX   Explore ILEX   ILEX Community ... ] doesn't even show up.

Removing the useragent override big allows it to work:
  user_pref("general.useragent.override", "Mozilla/4.0 (compatible; MSIE 6.0;
Windows NT 5.1)");

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113

Comment 6

15 years ago
WFm with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040127

Comment 7

15 years ago
WFM with firebird 0.8.0+ (20040120) on xp with my own prefs.js

Comment 8

15 years ago
The site sniffs UA and serves the wrong code to us if you spoof your UA. Not a bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 9

15 years ago
Further information for reporter:

In your prefs.js you've set the browser UA string to spoof your using IE6.  This
is a Bad Idea(tm), as Gecko can't understand some IEHTML (also some JScript not
in the DOM or the standardization of Javascript).  The server that gave you that
page saw you were running IE6 and gave you a version that should work for it
(and possibly not work for other browsers, like Mozilla).

There is one solution that should work for you, however, and won't screw up your
browsing totally.  Try the UA switcher extension (which appears to support
Mozilla in addition to Mozilla Firebird):

http://extensionroom.mozdev.org/more-info.php/useragentswitcher
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.