If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Build strips symbols despite configure-option --disable-strip

RESOLVED FIXED in 4.5.1

Status

NSPR
NSPR
RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: Christian Biere, Assigned: Wan-Teh Chang)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

745 bytes, patch
Brian Ryner (not reading)
: review+
Details | Diff | Splinter Review
(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; NetBSD i386; en-US; rv:1.5) Gecko/20031209 Firebird/0.7
Build Identifier: Mozilla 1.6

Although, I've configured Mozilla with --disable-strip, during the build strip
is invoked for several files.
Therefore, I can't provide backtrace with full symbol information.

Reproducible: Always

Steps to Reproduce:
1. configure --disable-strip
2. make > make.log 2>&1
3. grep strip make.log

Actual Results:  
[...[
strip libnspr4.so
strip libplds4.so
strip libplc4.so

Expected Results:  
It shouldn't have stripped the files.
NSPR uses a separate build system from the rest of the app, afaik....
Assignee: nobody → wchang0222
Component: Build Config → NSPR
Product: Browser → NSPR
QA Contact: core.build-config → wchang0222
Version: Trunk → other
(Assignee)

Comment 2

14 years ago
Created attachment 140028 [details] [diff] [review]
Proposed patch

NSPR's configure script also has a --enable-strip
option, but it is incorrectly implemented.  If
you specify either --enable-strip or --disable-strip,
it sets the make variable ENABLE_STRIP to 1!

After you apply this patch, remember to regenerate
NSPR's configure script:
    % cd mozilla/nsprpub
    % autoconf

I believe you can work around this bug by not
configuring Mozilla with --disable-strip because
I think stripping is disabled by default.
(Assignee)

Updated

14 years ago
Attachment #140028 - Flags: review?(bryner)
Attachment #140028 - Flags: review?(bryner) → review+
(Assignee)

Comment 3

14 years ago
Patch checked in on the NSPR trunk (NSPR 4.5.1) and
NSPRPUB_PRE_4_2_CLIENT_BRANCH (Mozilla 1.7a).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Target Milestone: --- → 4.5.1
You need to log in before you can comment on or make changes to this bug.