Closed Bug 231516 Opened 16 years ago Closed 16 years ago

Elements to the right of left float table are unresponsive

Categories

(Core :: Layout: Floats, defect)

x86
Linux
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 102695

People

(Reporter: grib, Unassigned)

References

()

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031107 Galeon/1.3.11a (Debian package 1.3.11acvs20040112-1)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031107 Galeon/1.3.11a (Debian package 1.3.11acvs20040112-1)

In test page (http://www.billgribble.com/floatprob.html), elements 
including <select> and <button> do not work as expected when they are laid out 
to the right of a table which is floated left.

For me, the items displaying text "works" ("hover works", "select works") work
fine, and the items displaying "broken" are unresponsive.  For example, the 
<select> displaying "Selection broken" does absolutely nothing when clicked
on (not popping up a list of its options).

While trying to prune down the test case, I found that the "titlebar" at the top
of the page is somehow relevant.  Removing it causes the problem to disappear. 

Reproducible: Always

Steps to Reproduce:
1.  Load http://www.billgribble.com/floatprob.html (or attachment to this bug)
2.  Click on the <select> showing the option "Selection broken".  Note that 
    it is broken (option list does not pop up). 
3.  Click on the <select> showing the option "Selection works".  Note that 
    it works (option list pops up)


Actual Results:  
"Broken" items did nothing.
"Works" items worked.

Expected Results:  
All items should work.

*** This bug has been marked as a duplicate of 102695 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
I was just about to say the same.  Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.