Bookmarks are not saved after closing the application

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
--
major
RESOLVED WORKSFORME
14 years ago
11 years ago

People

(Reporter: strangelove91, Assigned: Pierre Chanial)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

I had one of the latest Mozilla builds (not Firebird) before, then I had to
format and reinstall Windows 2000. Now I'm trying to use Firebird, since I like
it better, but all kind of weird stuff happens.

I had it downloaded on another computer before, so I copied on a CD to bring it
on my machine, placed it in "My Programs" - since there's no installer - applied
the "Pinball" theme, then proceeded to recover my bookmarks from another HD,
where I had them stored.

Everything seemed peachy, my toolbar had exactly the same buttons I previously
had on Mozilla, and the bookmarks seemed to be all there.

BUT...

Every time I open Thunderbird (after shutting it down completely) it reverts to
the original settings as it came. My bookmarks are gone. The toolbar only has
two buttons: "Mozilla Firebird Help" and "User Support Forum"... all else is
gone, and so are the rest of the bookmarks.

Even stranger, I tried to delete the entire "Mozilla Firebird" folder from
"Program Files" and downloaded a fresh copy.

Yet, when I launched, it already HAD the "Piinbal" theme installed, and no
matter how many times I tried to reinstall the favorites, every time I exit the
program and restart it, it's the same: it won't display my bookmarks, just the
ones it came up with.

I went inside the folder and found two "bookmark.html" files, which I replaced
with my own file. And still, it doesn't work. 

And when I go under "Documents and Settings > *my name* > User Data" there are
four folder with seemingly random names, but neither one of them has a ".slt"
file inside. Three are empty, the last one has a "oWindowsUpdate[1].xml" file
inside.

I am not a programmer, and therefore not comfortable with playing with all these
settings. What is going on? Why can't I uninstall it, and why does it refuse to
accept my new settings?

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

14 years ago
strangelove91, you'll need to create a new profile - this is where your
bookmarks, themes, and other personal information is kept.  Run
MozillaFirebird.exe with a -p option "MozillaFirebird -p", or if you want to
wipe your profile and start from scratch (careful, you'll loose bookmarks
etc..), you can put "%appdata%" into the windows explorer address bar, and
delete the Phoenix directory.

Try this and report back with how you go.

Comment 2

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

Same problem here.

Comment 3

14 years ago
Okay, little update. I removed my old profile. Now bookmark-saving works again.

Comment 4

14 years ago
you can self-invalidate it
WFM per reporter's comments
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
*** Bug 263716 has been marked as a duplicate of this bug. ***
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.