Charts rarely display correctly, java_vm spawns children, 100% cpu

RESOLVED EXPIRED

Status

Core Graveyard
Java: OJI
RESOLVED EXPIRED
15 years ago
8 years ago

People

(Reporter: Frank Ritchie, Assigned: Igor Kushnirskiy)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030821
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030821

When logged in with user account and generating charts they do not display
correctly if at all, especially when launching the chart applet from the market
matrix applet. Java_vm spawns children, CPU goes to 100%. Works fine in Windows
with Mozilla. 

Reproducible: Always

Steps to Reproduce:
1. Log in with an account name (free account is available)
2. Launch the market matrix applet 
3. Click on a symbol within the matrix to launch the java chart applet

Actual Results:  
chart applet consumes huge amount of system resources and locks up mozilla

Expected Results:  
display the java chart applet correctly

Comment 1

15 years ago
can you try again with 1.6 and most recent Sun's JRE 1.4.2_03 ?
I don't mean that upgrading will solve the issue magically, but having no
testcase or login to see the actual applet, it's mandatory to get a report with
latest milestone.
Component: Java-Implemented Plugins → Java: OJI
(Reporter)

Comment 2

15 years ago
Have tried 1.6 and Sun's JRE 1.4.2_03 with the same result 

(both RedHat and Suse running the gcc3.2 plugin)

Actually you do not need an account to test, follow these steps:

1. Go to http://www.prophet.net
2. From the top menu choose "Analyze" then "JavaCharts"

-you can also sign up for a free account to try the other method

Thanks,
Frank

Comment 3

15 years ago
wfm Firebird 20040119 trunk on Win2k, 0% CPU when viewing symbol "CSCO" for e.g.
Perhaps Linux-only issue ?
(Reporter)

Comment 4

15 years ago
definitely Linux only....works fine with Windows (I use it daily)

Comment 5

15 years ago
WFM LInux 2004020207 Blackdown-1.4.1-01 
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → EXPIRED

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.