"<!--[if !supportEmptyParas]--> <!--[endif]-->" visible in email sent from Thunderbird to Outlook Express

RESOLVED DUPLICATE of bug 247313

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 247313
15 years ago
14 years ago

People

(Reporter: Bruce Pick, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.0.3705)
Build Identifier: Mozilla Thunderbird 0.4 (20031205)

The text:   <!--[if !supportEmptyParas]--> <!--[endif]-->
shows up in email sent from my Thunderbird software.

Sending mail from Mozilla Thunderbird 0.4 (20031205) 
to Outlook Express v. 6.00.2800.1123

Occurred only when content from Microsoft Word document (version 2000 SP3)  was 
pasted into Thunderbird "Write" window and sent.  Unexpected text appeared in 
the email when received in Outlook Express, located between paragraphs.

Problem occurs only if sending as HTML, and only if pasting content directly 
from Word.  If I send as text only, it arrives cleanly as text.  

Reproducible: Always

Steps to Reproduce:
1. Open MS Word 
2. Type some text.  
3. Hit "Enter" twice to create a break.
4. Type some more.
5. Do more typing with additional breaks.
6. Put some font changes in the material.
     (This to ensure Thunderbird will go into HTML mode)
7. Copy, and paste into Thunderbird
8. Make sure it is sent in HTML mode.
Receive in Outlook Express to see the code showing in the email itself.

Actual Results:  
Incoming email message Source Code:
Received: from rwcrmhc11.comcast.net ([204.127.198.35])
          by sccrmxc14.comcast.net (sccrmxc14) with ESMTP
          id <20040120124030s14002m74le>; Tue, 20 Jan 2004 12:40:31 +0000
X-Originating-IP: [204.127.198.35]
Received: from comcast.net (pcp03676126pcs.nstnig01.ct.comcast.net
[68.60.221.10])
          by comcast.net (rwcrmhc11) with ESMTP
          id <20040120124029013008j0ohe>
          (Authid: bpick28);
          Tue, 20 Jan 2004 12:40:29 +0000
Message-ID: <400D2142.4020500@comcast.net>
Date: Tue, 20 Jan 2004 07:38:26 -0500
From: Bruce Pick <bpick28@comcast.net>
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6b) 
Gecko/20031205 Thunderbird/0.4
X-Accept-Language: en-us, en
MIME-Version: 1.0
To: Bruce Pick <brucepick1@comcast.net>
Subject: test
Content-Type: text/html; charset=us-ascii
Content-Transfer-Encoding: 7bit

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
  <title></title>
</head>
<body>
<p class="MsoNormal">Test</p>
<p class="MsoNormal"><!--[if !supportEmptyParas]-->&nbsp;<!--[endif]--
><o:p></o:p></p>
<p class="MsoNormal"><span style="font-family: &quot;Courier 
New&quot;;">Test<o:p></o:p></span></p>
<p class="MsoNormal"><!--[if !supportEmptyParas]-->&nbsp;<!--[endif]--
><o:p></o:p></p>
<p class="MsoNormal"><span style="font-family: &quot;Lucida 
Console&quot;;">Test<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-family: &quot;Lucida 
Console&quot;;">Test<o:p></o:p></span></p>
<p class="MsoNormal"><!--[if !supportEmptyParas]-->&nbsp;<!--[endif]--
><o:p></o:p></p>
<p class="MsoNormal"><span style="font-family: &quot;Bell 
MT&quot;;">Test<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-family: &quot;Bell MT&quot;;"><!--[if !
supportEmptyParas]-->&nbsp;<!--[endif]--><o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-family: &quot;Bell MT&quot;;"><!--[if !
supportEmptyParas]-->&nbsp;<!--[endif]--><o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-family: &quot;Bell 
MT&quot;;">Test<o:p></o:p></span></p>
<span style="font-size: 11pt; font-family: &quot;Bell MT&quot;;">Test</span>
</body>
</html>


Expected Results:  
Should receive clean email, without code showing in visible readable text.
Below is the message source code of results when composed in Outlook Express, 
received in Outlook Express (OK, they do have an advantage when sending to 
their own email client)

Received: from sccrmhc11.comcast.net ([204.127.202.55])
          by rwcrmxc15.comcast.net (rwcrmxc15) with ESMTP
          id <20040120124645r1500072ope>; Tue, 20 Jan 2004 12:46:46 +0000
X-Originating-IP: [204.127.202.55]
Received: from BP10001 (pcp03676126pcs.nstnig01.ct.comcast.net[68.60.221.10])
          by comcast.net (sccrmhc11) with SMTP
          id <2004012012464501100j8hs2e>; Tue, 20 Jan 2004 12:46:45 +0000
Message-ID: <004801c3df53$2ce04240$0200a8c0@BP10001>
From: "Bruce Pick" <brucepick1@comcast.net>
To: "Bruce Pick" <brucepick1@comcast.net>
Subject: Test From OutlookExpr to OutlookExpr
Date: Tue, 20 Jan 2004 07:44:40 -0500
MIME-Version: 1.0
Content-Type: multipart/alternative;
	boundary="----=_NextPart_000_0045_01C3DF29.42B24B60"
X-Priority: 3
X-MSMail-Priority: Normal
X-Mailer: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165

This is a multi-part message in MIME format.

------=_NextPart_000_0045_01C3DF29.42B24B60
Content-Type: text/plain;
	charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

Test

=20

Test

=20

Test

Test

=20

Test

=20

=20

Test

Test
------=_NextPart_000_0045_01C3DF29.42B24B60
Content-Type: text/html;
	charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=3DContent-Type content=3D"text/html; =
charset=3Diso-8859-1">
<META content=3D"MSHTML 6.00.2800.1276" name=3DGENERATOR>
<STYLE></STYLE>
</HEAD>
<BODY bgColor=3D#ffffff>
<DIV>
<P class=3DMsoNormal style=3D"MARGIN: 0in 0in 0pt"><FONT =
face=3DArial>Test</FONT></P>
<P class=3DMsoNormal style=3D"MARGIN: 0in 0in 0pt"><FONT=20
face=3DArial>&nbsp;<?xml:namespace prefix =3D o ns =3D=20
"urn:schemas-microsoft-com:office:office" /><o:p></o:p></FONT></P>
<P class=3DMsoNormal style=3D"MARGIN: 0in 0in 0pt"><SPAN=20
style=3D"FONT-FAMILY: 'Courier New'">Test<o:p></o:p></SPAN></P>
<P class=3DMsoNormal style=3D"MARGIN: 0in 0in 0pt"><FONT=20
face=3DArial>&nbsp;<o:p></o:p></FONT></P>
<P class=3DMsoNormal style=3D"MARGIN: 0in 0in 0pt"><SPAN=20
style=3D"FONT-FAMILY: 'Lucida Console'">Test<o:p></o:p></SPAN></P>
<P class=3DMsoNormal style=3D"MARGIN: 0in 0in 0pt"><SPAN=20
style=3D"FONT-FAMILY: 'Lucida Console'">Test<o:p></o:p></SPAN></P>
<P class=3DMsoNormal style=3D"MARGIN: 0in 0in 0pt"><FONT=20
face=3DArial>&nbsp;<o:p></o:p></FONT></P>
<P class=3DMsoNormal style=3D"MARGIN: 0in 0in 0pt"><SPAN=20
style=3D"FONT-FAMILY: 'Bell MT'">Test<o:p></o:p></SPAN></P>
<P class=3DMsoNormal style=3D"MARGIN: 0in 0in 0pt"><SPAN=20
style=3D"FONT-FAMILY: 'Bell MT'">&nbsp;<o:p></o:p></SPAN></P>
<P class=3DMsoNormal style=3D"MARGIN: 0in 0in 0pt"><SPAN=20
style=3D"FONT-FAMILY: 'Bell MT'">&nbsp;<o:p></o:p></SPAN></P>
<P class=3DMsoNormal style=3D"MARGIN: 0in 0in 0pt"><SPAN=20
style=3D"FONT-FAMILY: 'Bell MT'">Test<o:p></o:p></SPAN></P><SPAN=20
style=3D"FONT-SIZE: 11pt; FONT-FAMILY: 'Bell MT'; mso-bidi-font-size: =
12.0pt; mso-fareast-font-family: 'Times New Roman'; =
mso-bidi-font-family: 'Times New Roman'; mso-ansi-language: EN-US; =
mso-fareast-language: EN-US; mso-bidi-language: =
AR-SA">Test</SPAN></DIV></BODY></HTML>

------=_NextPart_000_0045_01C3DF29.42B24B60--



Should be repaired because a primary feature of Thunderbird is its cross-
platform capabilities.

I am seriously considering moving my email to Thunderbird for its spam-blocking 
capabilities.  If I cannot bring in formatted text from MS Office applications 
I may have to stay with Outlook Express.

Thank you!

Comment 1

15 years ago
This also occurs when replying to e-mails that were composed and formatted in
Outlook.  Affects Mozilla Mail as well as Thunderbird.

Comment 2

14 years ago
This also happens with Netscape 7.1 with WinXP.
I found the following workaround (I know it will not work
in all situations!):
Open the word-document not in WinWord, but in Wordpad and copy
the content with the clipboard to the e-mail program.

The Wordpad coming with WinXP seems to be able to read
perfectly the WinWord-documents from Office 2000.

Because of this workaround, I'm pretty sure, there is a
WinWord setting to affect this behaviour, but I couldn't find
any.

Comment 3

14 years ago
I reported this bug long time ago as Mozilla Mail bug..
It didn't happen for a long time already..(that's why I forgot the bug ID and 
when did I report this bug)

now it appear again?

Comment 4

14 years ago
The problem is better described at the dupe.

*** This bug has been marked as a duplicate of 247313 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.