Some html elements are mis-drawn when using width=100%

RESOLVED INVALID

Status

()

Core
Layout: Tables
--
minor
RESOLVED INVALID
14 years ago
13 years ago

People

(Reporter: Stuart Clark, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040120 Firebird/0.8.0+ (scragz)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040120 Firebird/0.8.0+ (scragz)

Login details to test this error:
username: test@kbsm.org
password: firebirdtest

When using this webmail application, and the "Outlook" or "Outlook 2003" skins,
the folder buttons on the left iframe are screwed up. Their coding includes use
of the "width=100%" statement. This behaviour does not occur using the current
0.8 branch builds.


Reproducible: Always

Steps to Reproduce:
1. Login to webmail using account details above
2. Ensure you're looking at the Outlook or Outlook 2003 skins. (use the Settings
button to check)


Actual Results:  
Folder buttons (Add, Modify, Delete) and text box are screwed up.

Expected Results:  
Correct results can be seen using FB 0.8 branch or Moz 1.6 builds.

If anymore info is needed, I can post the source code which relates to this issue.
also seeing this on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a)
Gecko/20040117
Assignee: blake → nobody
Component: General → Layout: Tables
Product: Firebird → Browser
QA Contact: core.layout.tables
Version: unspecified → Trunk

Comment 2

14 years ago
<form>
	<input style="float: right;">
	<input style="width: 100%;">
</form>

The second input draws over the first because the 100% refers to the containing
block (the window), not the available space.

I think.
(Reporter)

Comment 3

14 years ago
(In reply to comment #2)
> The second input draws over the first because the 100% refers to the containing
> block (the window), not the available space.

I agree the code in the test site doesn't make this easy to figure out, but what
I have done is extensive testing to find how it *should* be coded to work correctly.

If the code is changed to work in Mozilla/5.0 (Windows; U; Windows NT 5.1;
en-US; rv:1.7a) Gecko/20040120 Firebird/0.8.0+ (using values like 65%), then it
won't display properly when tested in Mozilla/5.0 (Windows; U; Windows NT 5.1;
en-US; rv:1.6) Gecko/20040120 Firebird/0.7+

To my mind, although not serious, something has changed to "alter" the way the
code is drawn on the skin, which is having a less than good effect.

Comment 4

14 years ago
Stuart could please you attach the stuff you have done as testcases to this bug?

Comment 5

13 years ago
Well, that site doesn't work anymore and there's no response from the reporter.
As far as I can tell, the code I posted in comment 2 works as expected. So
marking invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.