Dragging a link from a page in sidebar onto the close-tab-button spawns two tabs instead of one

VERIFIED INVALID

Status

()

Firefox
Bookmarks & History
--
minor
VERIFIED INVALID
14 years ago
9 years ago

People

(Reporter: michaelk, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7a) Gecko/20040120 Firebird/0.8.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7a) Gecko/20040120 Firebird/0.8.0+

To open a link from the sidebar in a new tab (for example from a link-list you
bookmarked to open in sidebar), you can drag it onto the tab-bar. If the tab-bar
is full, you can drag it onto the close-tab-button.
Dragging a link from a normal tab to the close-button creates one tab (as
expected), while dragging a link from the sidebar onto the tab-close-button (not
sidebar-close-button) creates two!


Reproducible: Always

Steps to Reproduce:
1. Start Mozilla Firebird
2. Create a bookmark, for example to "http://mozilla.org", and check 
   the box titled "Load this Bookmark in the sidebar" in the bookmarks prefs.
3. Open the bookmarked page in sidebar by activating the bookmark.
4. Open another tab in the main window or uncheck the "Hide tab-bar when 
   only one web-page is open" preference to show the tab-bar.
5. Drag any link (for example "Make a Donation") onto the tab-close-button
   which resides in the upper right corner of the tab-bar.

Actual Results:  
Two tabs spawn, each loading the url of the link that was dragged.

Expected Results:  
Firebird should spawn only one tab to open the link.

I found this bug using Mac OS 10.3.2, 
I could not reproduce it running 2004-01-16 on Windows XP

Comment 1

14 years ago
confirmed Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7a)
Gecko/20040202 Firebird/0.8.0+.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

13 years ago
Confirmed on Mac OS X v10.3.6

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041109
Firefox/1.0 (PowerBook)
Assignee: hyatt → vladimir+bm
Component: Toolbars → Bookmarks
QA Contact: bugzilla → mconnor

Comment 3

13 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050720
Firefox/1.0+.

Comment 4

13 years ago
But I do see this bug using Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O;
en-US; rv:1.8b4) Gecko/20050819 Firefox/1.0+ ID:2005081916

I guess this bug is Mac-only.
Assignee: vladimir+bm → nobody
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks

Comment 6

9 years ago
Marking invalid, relies on an old feature that's no longer present, the single close-tab button on the tab bar.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
(Reporter)

Comment 7

9 years ago
Yep, my original report no longer applies.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.