If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"close all tabs" confirmation will close whether close or cancel is chosen

VERIFIED INVALID

Status

SeaMonkey
Tabbed Browser
VERIFIED INVALID
14 years ago
9 years ago

People

(Reporter: Charles Herold, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

When I have more than one tab open in a browser and I close the browser window
using the upper right hand X or the alt-F4 key combination, I get a confirm
close dialogue box with a choice of "close all tabs" or "cancel".  Whichever one
I click on, the window will close.

Reproducible: Always

Steps to Reproduce:
1.Open multiple tabs
2.close the browser with alt-F4 or by clicking the upper right hand X
(cntrl+shift+w or using the menu to choose "close window" work correctly,
allowing you to cancel the confirm box).
3. When the confirm box comes up, click on cancel

Actual Results:  
the browser window with all tabs will close even after clicking on cancel

Expected Results:  
It should close the window only if you click on "close all tabs," while it
shouldn't do anything when you click on cancel except to make the confirm box
disappear.

I didn't bother reporting this in 1.5 because I though someone else was bound to
notice and report it, but since it's not fixed in 1.6 I thought I'd better say
something.
I've seen this on every version of Mozilla I've run for any good length of time
(meaning every single alpha, beta, release candidate, and final build since
about 1.4a.)

Confirming because this is definately a bug, although I'd be pretty surprised if
this isn't a dup.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

14 years ago
Bug 222316 tells a lot, and has links to dupes, 
do you have extensions installed?
Bug 222316 says this is an issue in the Download Statusbar extension.  Reporter,
is this extension installed on your Mozilla?  It is, and nearly always has been
installed on mine.
(Reporter)

Comment 4

14 years ago
Yes, I have download statusbar installed, so that's the problem.  So this 
should be set to INVALID.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
Verifying.
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.