CreateProfile command line argument doesn't work



Core Graveyard
Profile: BackEnd
14 years ago
2 years ago


(Reporter: Marc DVer, Unassigned)


Windows XP

Firefox Tracking Flags

(Not tracked)




14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)
Build Identifier: Mozilla 1.6 Gold

I have a script that copies my profile from my thumb drive to the pc, and then 
creates a profile in mozilla with the path of the profile.  The files move 
alright, but Mozilla never seems to be able to find the profile.  I've tried 
this on several computers with fresh images, but never works, no matter how 
much I mess with the scripts.

Reproducible: Always

Steps to Reproduce:
1.  Create profile on orginal computer.
2.  Use the profile, like get mail, etc.
3.  Copy profile to another directory on orginal drive, like c:\sandbox.
4.  Reassign the profile to the directory on the original computer.  It works.
5.  Copy profile to thumb drive.
6.  Copy from thumb drive to new computer, using c:\sandbox.
7.  Install mozilla.
8.  Use the following two lines to create the profile and start mozilla:
"c:\program files\\mozilla\mozilla.exe" -createprofile "default 
c:\sandbox\Application Data\Mozilla\Profiles\default\733jdoma.slt\"
"c:\program files\\mozilla\mozilla" -p"default"

Actual Results:  
Mozilla opens with the fresh install defaults, like the homepage, and mail 
isn't available.

Expected Results:  
I should have seen the normal startup home page and be able to see my mail.
Assignee: general → nobody
Component: Browser-General → Profile Manager BackEnd
QA Contact: general → core.profile-manager-backend

Comment 1

14 years ago
Have you tried using unsalted profiles? I think if you try the procedure
explained at you'll find that
-createprofile works as designed. Note the difference in syntax between there
and what you are doing. Salting isn't the issue, but unsalting would make your
typing job easier. Profiles need be located neither on your boot drive nor in
such a long-winded directory nest.

Comment 2

14 years ago
I believe this may be a duplicate of Bug 51509.  I modifying the procedure given
to me on a previous post to this bug, and it didn't work.

*** This bug has been marked as a duplicate of 51509 ***
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 3

14 years ago
I just tried it by using an underscore in Application_Data, and it still doesn't
work.  For some reason, an Application Data directory is being created, even
though the batch specifies the underscore in both the %appdata% variable and in
the path for createprofile.  
Resolution: DUPLICATE → ---

Comment 4

14 years ago
I tried putting in a nonsense path into the createprofile command argument, and
it put it where expected.  However, when I went into the profile manager gui,
the profile didn't show up.  As there is no output to the console when a profile
creation fails, I cannot make a further diagnosis.  Can someone tell me of a
build that has debugging info that goes to the console?  I have access to, so I should be able to compile a build, though I would prefer a binary.

Comment 5

14 years ago
Is there a file outside the profile directory that lists all the profiles and
locations for a computer?  It could be that that file doesn't get updated by
-createprofile for some reason, and therefore when Mozilla looks for the path
for the profile, it sees invalid data.  Perhaps someone should compare the code
used by the command line argument and the code used by the profilewizard.  I'm
not skilled enough to make heads or tails of the Mozilla code, and probably
won't be for a number of years.

Comment 6

13 years ago
Could you attach your script so people can have a look at it?
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Last Resolved: 14 years ago13 years ago
Resolution: --- → EXPIRED


2 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.