Firebird doesn't automatically accept encodings different from UTF-8 in Xhml-compliant pages

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
15 years ago
15 years ago

People

(Reporter: dietmar_temme, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

The page starts with the definition of XHTML-Compliance:

<?xml version="1.0" encoding="iso-8859-1"?>
<!doctype public "-//w3c//dtd xhtml 1.0 transitional//en"
 "http://www.w3.org/tr/xhtml1/Dtd/xhtml1-transitional.dtd" />
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="de" lang="de">
<head>
<meta http-equiv="content-type" content="text/html; charset=ISO-8859-1">

The page is rendered with the correct encoding only after explicit setting the
language/encoding over the menu - but returns to UTF-8 on a reload-page.

Reproducible: Always

Steps to Reproduce:
1. make a small page starting as above and containg some german diacritic vocals
(Umlaute) like ä ö ü Ä Ö Ü or ß - (you may cut and paste this).
2.look at it with Firebird
3.use menu: view-coding to change
4. reload 


Expected Results:  
recognize the correct encoding.

Comment 1

15 years ago
It works for me in:

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7a) Gecko/20040120 Firebird/0.8.0+

Page shows up correctly, encoding is listed as ISO-8859-1 in the Page Info screen.

Could you try on a more recent build?

p.s. I think the public identifier part of a doctype declaration ("-//w3c//dtd
xhtml 1.0 transitional//en") is case sensitive, so don't transform that part to
lower case, and you are missing the name of the root element (html) from the
declaration.

Comment 2

15 years ago
Closing as WORKSFORME since there has been no further response. Reporter please
reopen the bug if you can still reproduce it on a recent build:

ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.