Mozilla and Firebird fail to show large PNG files which all other browsers are happy to

RESOLVED DUPLICATE of bug 113406

Status

Core Graveyard
Image: Painting
--
major
RESOLVED DUPLICATE of bug 113406
15 years ago
9 years ago

People

(Reporter: Shane Sturrock, Assigned: Jim Dunn)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4.1) Gecko/20031008
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4.1) Gecko/20031008

Any large PNG file that I try to view simply shows the broken image icon.  If I
view the same image using Safari or IE it displays fine.  Mozilla claims the
image has errors.  Mozilla on Windows or Linux work fine.

Reproducible: Always

Steps to Reproduce:
1.  Get a large PNG file
2.  Open it with Mozilla on MacOS X
3.  Open same image on Safari

Actual Results:  
Safari shows the image fine, Mozilla 1.4 and Firebird (Nightly 20 Jan 2004)
don't.  It also works fine on Mozilla on Windows or Linux so this just affects OS X.

Expected Results:  
Should have shown the image.

If I try and open the image file I get "The image
"file:///Users/sss/Desktop/big_image.png" cannot be displayed, because it
contains errors.
(Reporter)

Comment 1

15 years ago
Created attachment 139561 [details]
Just a large image

This image fails on every version of Mozilla and Firebird I have tried on OS X
but works fine on Safari and also works on Mozilla and Firebird on Windows and
Linux.

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 113406 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Component: ImageLib → Image: GFX
Resolution: --- → DUPLICATE

Updated

9 years ago
Component: Image: Painting → Image: Painting
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.