Closed Bug 231724 Opened 19 years ago Closed 16 years ago

Exporting vCalendar file format incompatible with some external devices

Categories

(Calendar :: Import and Export, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: psayago, Unassigned)

References

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031208
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b) Gecko/20031208

I own a T610 Sony Ericsson mobile phone that can read vCalendar files. When I
try to read vCalendar files generated with Mozilla Calendar does not work. I've
opened Mozilla Calendar vCalendar files and compared them with my phone
generated files and I think the difference is in the way Mozilla Calendar treat
CR and LF characters.

Reproducible: Always

Steps to Reproduce:
1.Create an event in Mozilla Calendar
2.Export the event in vCalendar format
3.Send the file to my phone through bluetooth

Actual Results:  
My phone recognize the file but no event name is displayed, and the event is not
loaded by the phone.

Expected Results:  
Nothing

As I said I think its a problem with CD and LF export filter, because Sony
Ericcson T610 export files are in Win32 format.
If possible please attach a vCalendar file that works with the T610
Comment on attachment 139894 [details]
T610 vCalendar export file

This is the file T610 recognize perfectly
The iCalendar spec calls for \r\n newlines.

Mozilla Calendar 2004040814-cal for Netscape 7.1 on Windows 2000 _and_	Mozilla
Sunbird/0.1.1+ on Windows 2000 export calendar files which have only \n instead
of the \r\n which the spec requires.

The consequence is that applications which read exported calendars fail to do
so through no fault of theirs.

Please add the \r.

This is a bug that should be fixed.
Attachment #155625 - Attachment description: exported calendar file format violates spec → exported calendar file format violates spec \n used instead of \r\n
Problem may be in libical icalcomponent_as_ical_string() ?

(When this is fixed, note that javascript function patchICalStringForExport()
may need to be changed.
http://lxr.mozilla.org/mozilla/source/calendar/resources/content/importExport.js#829
)
Depends on: 255121
(In reply to comment #4)
> Created an attachment (id=155625)
> exported calendar file format violates spec
> 
> The iCalendar spec calls for \r\n newlines.
> 
> Mozilla Calendar 2004040814-cal for Netscape 7.1 on Windows 2000 _and_	Mozilla
> Sunbird/0.1.1+ on Windows 2000 export calendar files which have only \n instead
> of the \r\n which the spec requires.

Can you point me to the bit of the appropriate RFC or Standard that says this?
I think bug 255121 fixed the \r\n problem for exporting ics and vcs files.
Is \r\n still a problem?

(p.s. \r\n are specified in RFC 2445 sec 4.1 Content lines)
Pedro,
Can you confirm that this bug is or is not fixed in the latest Sunbird release?

Thanks
Sunbird 0.2 dont fix my problem. When Sunbird generates a vCalendar file, it
does with this format:
BEGIN:VCALENDAR
VERSION
 :2.0
PRODID
 :-//Mozilla.org/NONSGML Mozilla Calendar V1.0//EN
METHOD
 :PUBLISH
BEGIN:VEVENT
UID
 :7fc113ee-1dce-11d9-96e9-aca8b7518fea
SUMMARY
 :DummyTitle
LOCATION
 :DummyLocation
STATUS
 :TENTATIVE
...

But the device I own needs the data fields not separated by new line:
BEGIN:VCALENDAR
VERSION:2.0
PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.0//EN
METHOD:PUBLISH
BEGIN:VEVENT
UID:7fc113ee-1dce-11d9-96e9-aca8b7518fea
SUMMARY:DummyTitle
LOCATION:DummyLocation
STATUS:TENTATIVE
...

I dont know if it is a problem of my device or the vcs file specification, but
thanks for your work. :-)
Currently it just outputs the iCalendar file, but iCalendar allows newlines in
places where vCalendar does not.  Bug 264447 has been created for this issue.
Depends on: 264447
I am using 2004091012-cal on XP under firebird and find the opposite problem. 
All the lines now end in \r\r\n - which is one \r too many.  This breaks
compatibility with other organisers like korganiser (which now refuses to
recognise the file).  Maybe this has gone one fix too far.  See bug 266108.
Reporter,
Since all the bugs this bugs depends on have been fixed, would you please verify
with the latest builds if this bug still exists or not?
(In reply to comment #12)
> Reporter,
> Since all the bugs this bugs depends on have been fixed, would you please verify
> with the latest builds if this bug still exists or not?

I've got the same problem when importing vCal file in Kwartz server from
Sunbird: too many \r make file unreadable. If I manually remove these extra \r,
the file is correctly imported.
This bug still exists in RC1 version.
Just to clarify:
  Both vCalendar and iCalendar files contain BEGIN:VCALENDAR
  vCalendar files contain VERSION:1.0 and usually have file suffix .vcs
  iCalendar files contain VERSION:2.0 and usually have file suffix .ics
  To export a vCalendar file, you need to 
    select events, 
    File -> Export Selected Events...
    Save as type:  vCalendar Files   (not default, Calendar Files [iCalendar])
    Save

    
QA Contact: gurganbl → general
Reassigning all automatically assigned bugs from Mostafa to nobody@m.o

Bugspam filter: TorontoMostafaMove
Assignee: mostafah → nobody
Component: General → Import and Export
QA Contact: general → import-export
Nominating for marking INVALID, because we don't support VCS export anymore.
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Keywords: qawanted
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.