XHTML+SMIL support in mozilla

RESOLVED WONTFIX

Status

SeaMonkey
General
--
enhancement
RESOLVED WONTFIX
15 years ago
14 years ago

People

(Reporter: Kees, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031114
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031114

As I saw in several closed bugs, requests to get SMIL 2.0 support in mozilla
were denied. I agree SMIL 2.0 is better supported through a plugin like realplayer.
XHTML+SMIL however is about extending XHTML with some parts of SMIL (not the
whole thing.)
The XHTML+SMIL note has been in existance for at least 2 years now:
http://www.w3.org/TR/XHTMLplusSMIL/

XHTML+SMIL reuses several technologies already in mozilla. Like CSS for defining
layout and XHTML for linking. So I think this is a candidate for implementation
in mozilla. XHTML+SMIL is already in IE since version 5.5. Time to catch up ;-)


Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 2

15 years ago
Is this bug about SVG Declarative Animations (in which case it should be
renamed) or about XHTML+SMIL support in general (in which case SVG is the wrong
component)?
(Reporter)

Comment 3

15 years ago
About XHTML+SMIL support in general because it's not specifically about SVG support.

Comment 4

15 years ago
(In reply to comment #3)
> About XHTML+SMIL support in general because it's not specifically about SVG
support.

In that case ... rassigning to browser-general :-)
Assignee: alex → general
Component: SVG → Browser-General
QA Contact: general
That document is a note, not a recommendation. But this would be WONTFIX for the
same reasons as bug 93321.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.