Camino can't use the system proxy settings via a .pac

RESOLVED FIXED in Camino1.0

Status

Camino Graveyard
OS Integration
P3
normal
RESOLVED FIXED
14 years ago
13 years ago

People

(Reporter: Gabriel Radic, Assigned: Simon Fraser)

Tracking

({fixed1.8})

unspecified
Camino1.0
PowerPC
Mac OS X
fixed1.8

Details

Attachments

(1 attachment)

6.34 KB, patch
Mike Pinkerton (not reading bugmail)
: review+
Details | Diff | Splinter Review
(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021104 Chimera/0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021104 Chimera/0.6

Since Mac OS X 10.3.2 you can specify a .PAC (Proxy Client Autoconfig) file in
the Network/Proxy preference pane. If a .pac file is defined while no settings
are provided for each service, Camino can't find it's way out. 

Everything works fine if a proxy server is specified for each service (web,
secure, ftp, etc)


Reproducible: Always

Steps to Reproduce:
how does mozilla behave? if it's the same, we should kick the bug over there.
Summary: Camino can't use the system proxy settings via a .pac → Camino can't use the system proxy settings via a .pac
(Reporter)

Comment 2

14 years ago
AFAIK Mozilla does NOT use the system proxy settings but the internal
Advanced/Proxy configuration. 

So I guess this must be Camino specific.
wait, camino and mozilla should be doing the same thing. neither use the system
settings, both use mozilla's proxy autoconfig.

i'm confused.
(Reporter)

Comment 4

14 years ago
I am 100% sure Camino is using the system proxy settings. I changed those recently to use a .pac 
instead of individual settings and Camino stopped working. I then added back the settings for the 
Web service and Camino works again.

Comment 5

13 years ago
Gabriel please update.
(Reporter)

Comment 6

13 years ago
Jasper: the problem is still here with 2004082512 (v0.8.1).

Comment 7

13 years ago
This is still a problem as of 2004111008 (v0.8+).
It IS Camino specific since Camino uses system proxy settings and Mozilla uses it's own setitngs.

Comment 8

13 years ago
I can additionally confirm the existence.  In the 12/13/2004 nightly, Camino
won't use the .pac file specified in the system wide settings.  Safari uses it
correctly.  If I specify a proxy specifically in the system wide settings (not
using the .pac) Camino uses it.  Firefox and Mozilla use their own settings (not
the OSX systemwide ones) and are not affected by this.  However, I can add the
proxy autoconfig (.pac) to Camino by adding the

user_pref("network.proxy.type", 2);
user_pref("network.proxy.autoconfig_url","path-to-.pac-file");

to my user.js file.

Comment 9

13 years ago
Confirming bug and marking as new as many users say it's an issue. Mike please
takea look and comment on what should be done. Sound like something that should
be documented.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → Future

Updated

13 years ago
QA Contact: benc
(Assignee)

Comment 10

13 years ago
Yes, we have code to use the system proxy settings (I wrote it). See
-readSystemProxySettings in PreferenceManager.mm.
Priority: -- → P3
Target Milestone: Future → Camino1.0

Comment 11

13 years ago
(In reply to comment #10)
> Yes, we have code to use the system proxy settings (I wrote it). See
> -readSystemProxySettings in PreferenceManager.mm.

Do you mean this file (CVS rev 1.50)?

http://lxr.mozilla.org/mozilla/source/camino/src/preferences/PreferenceManager.mm#502

I don't know Objective C, but I suspect that it is only getting the statically
configured proxy settings (and it is not reading the .pac file URL from System
Preferences).

I was going to poke around and see what about:config says that
network.proxy.type is set to, but this nightly build (2005062008) doesn't
display anything in the about:config listbox (just the column headers under the
filter box/button).

Any suggestions for tracking this down?
(Assignee)

Comment 12

13 years ago
Oh, right, we just read mozilla prefs to get the PAC settings; we don't read
this from system prefs yet.
(Assignee)

Updated

13 years ago
Blocks: 185288
(Assignee)

Updated

13 years ago
Assignee: pinkerton → sfraser_bugs
(Assignee)

Comment 13

13 years ago
Created attachment 193179 [details] [diff] [review]
Patch (-w)

This patch allows camino to read the system PAC settings if they exist. I had
to sniff the dictionary keys from a 10.4SDK build, because they aren't present
in the 10.2 SDK, but it's unlikely they'd change.

I also added new hidden pref, "camino.use_system_proxy_settings", defaulting to
true, which affects whether we read the proxy settings from the OS at all. This
is so that people can specify a PAC file in the camino prefs without getting it
clobbered by the OS settings.
Attachment #193179 - Flags: review?(pinkerton)
Comment on attachment 193179 [details] [diff] [review]
Patch (-w)

r=pink

just make sure we update the documentation to mention this new pref needs to be
set in order to use a PAC file.
Attachment #193179 - Flags: review?(pinkerton) → review+
(Assignee)

Comment 15

13 years ago
Samuel: can you document this "camino.use_system_proxy_settings" pref please?
Status: NEW → ASSIGNED
(Assignee)

Comment 16

13 years ago
Fixed on trunk and branch.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Updated

13 years ago
Keywords: fixed1.8
You need to log in before you can comment on or make changes to this bug.