Closed Bug 231738 Opened 21 years ago Closed 21 years ago

Import/Export dialogs should not have :'s in their titles

Categories

(SeaMonkey :: Bookmarks & History, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: timeless, Assigned: durbacher)

Details

Attachments

(1 file, 1 obsolete file)

Steps:
1. run mozilla for windows (1.6 branch or trunk from this week)
2. in navigator, select File>Open File...
2' observe window title "Open File"
3. cancel/escape/close window
4. Bookmarks>Manage Bookmarks
5. in bookmark manager, select Tools>Import...
5' observe window title "Import bookmark file:"

Expected results: no ":" in title.

for reference,...
* outlook has a vcard import dialog which is titled "VCARD File"
* outlook has a vcalendar/icalendar import dialog which is titled "Browse"
* the standard OLE create from file dialog is titled "Browse"
* outlooks PST add feature (control panel: Mail) has "Create or Open Outlook
Data File"
* driver .inf "Install From Disk" dialog provides a dialog titled "Locate File"
* the fonts folder has an "Install New Font..." option which provides a (and
perhaps the ugliest) dialog titled "Add Fonts" (it's actually kind of cute, try
browsing to a java2\jre\lib\fonts directory)

It seems that all of these dialogs use "Title Caps" (note that 'or' is not
capitalized) instead of "Sentence caps"
cc'ing me is an invitation to fix it?  ;-)

Mozilla Mailnews import has "Select address book file"
Netscape 4 has "Import bookmarks file"
So maybe still small letters?
But NS 4 also has "Export As" and "Address Book Info", "Save As..." (dots!) and
"Open Page" (no dots!), which makes it seem quite inconsistent.

But this brings up another question: plural or singular?
Not only NS 4 but also Mozilla mostly uses plural for bookmarks.

IE 5 (german) has "Lesezeichen-Datei auswählen" (select bookmarks file) and
"Webseite speichern" (save web page). Only nouns have capital letters here.
Mozilla, again, has "Save As". Ugh.

I'd be willing to make a patch, but I think somebody should decide first which
capitalization should be used - consistently throughout the app.

When looking through http://www.mozilla.org/mailnews/specs/, there were only two
labels containing small letters:
"Select Items for Offline Usage" and
"Download and Sync Messages"

http://mozilla.org/projects/ui/communicator/browser/bnh doesn't say anything.

I know these specs are old, but at least someone thought about standardizing
things back then...

After all, I think whatever we choose, "Select address book file" is wrong. This
has also to be changed and it should not influence our decision.

My suggestion is: either all in Caps or all nouns in Caps.
Either way the Address book and bookmarks import/export labels should all be all
Caps. Other opinions on this?
Title caps looks good to me.
one note, the title caps rule is the rule we're using for en-*

if german has another rule, that's it's own business.
and if german can't use its own string, then that's our bug and we should fix it.

sure, please fix it :), thanks :)
Assignee: p_ch → durbacher
cc'ing varga to get a final word on it from him and pch.
The only question left seems to be "Bookmark" or "Bookmarks".
I'd prefer the latter, but that would also require a change in the tools menu of
the bookmark manager where it says "Open Bookmark File...". But I'm no native
English speaker...
Attached patch proposal (obsolete) — Splinter Review
There was lots of trailing whitespace on two of those lines. Does that serve
any purpose? I could not see any change after removing it... 
This whitespace originated from pch's rewrite checkin so he should know whether
or not... There are three more lines with such trailing whitespace that also
could be removed.
i have to agree, it's a bookmarks file, not a bookmark file. but if you want to
fix that for all the relevant places in another bug, you're welcome to do so :)
- otherwise you can just do it here.
I'm not an English speaker either, but "Import/Export/Open Bookmark File" sounds
a bit like there's only one bookmark in that file.
So I'm all for changing it to "... Bookmarks File"
Attached patch patchSplinter Review
Ok, this way.
Attachment #139662 - Attachment is obsolete: true
Status: UNCONFIRMED → NEW
Ever confirmed: true
Comment on attachment 139665 [details] [diff] [review]
patch

Jan, ok, so I need r=...

These are all occurrences of "bookmark file" in lxr apart from a help file that
 has both plural and singular. I'll file a bug on that once this goes in.
Attachment #139665 - Flags: review?(varga)
Comment on attachment 139665 [details] [diff] [review]
patch

r=varga
Attachment #139665 - Flags: review?(varga) → review+
Comment on attachment 139665 [details] [diff] [review]
patch

Requesting sr= from alecf.
Attachment #139665 - Flags: superreview?(alecf)
Comment on attachment 139665 [details] [diff] [review]
patch

sr=alecf
translators are going to be overjoyed.
Attachment #139665 - Flags: superreview?(alecf) → superreview+
Fix checked in.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: