problem with published ical format. apple ical cannot parse. only first event appears.

RESOLVED DUPLICATE of bug 179985

Status

Calendar
General
RESOLVED DUPLICATE of bug 179985
14 years ago
12 years ago

People

(Reporter: kilian koepsell, Assigned: Mostafa Hosseini)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-us) AppleWebKit/106.2 (KHTML, like Gecko) Safari/100.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113

when i publish a calendar in the ical format, every event is not only sandwiched between

BEGIN:VEVENT
END:VEVENT

but also in between 

BEGIN:VCALENDAR
END:VCALENDAR

apples ical stops parsing the file after the first 'END:VCALENDAR'. therefore, it is not possible to 
subscribe to a remote calendar which is produced by mozilla.

Reproducible: Always

Steps to Reproduce:
1. create calendar with at least two events
2. publis the calendar in ical format
3. import ical file into apple ical
Actual Results:  
only the first event is displayed.

Expected Results:  
all events should be displayed

ical version 2004010914-cal
(Assignee)

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 179985 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
The bugspam monkeys have been set free and are feeding on Calendar :: General. Be afraid for your sanity!
QA Contact: gurganbl → general
You need to log in before you can comment on or make changes to this bug.