after entering an IMAP folder, check for new mail makes mozilla set the old number for new messages

RESOLVED WORKSFORME

Status

MailNews Core
Networking: IMAP
RESOLVED WORKSFORME
15 years ago
10 years ago

People

(Reporter: René, Assigned: Bienvenu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.1; Linux; de, DE, de_DE@euro)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.6) Gecko/20040113

When I read new mail in an IMAP folder, the number of new messages changes as 
it should. But when I leave that folder and check for new mail, the old number 
of new messages is set again and again. I am using imap.web.de as IMAP server 

Reproducible: Always

Steps to Reproduce:
1. go online 
2. enter IMAP folder, read new messages 
3. leave folder, check for new mail 
Actual Results:  
The folder overview in the left column shows the same number of unread 
messages as before entering that folder and reading the messages. 

Expected Results:  
Remember the new number of read/new messages resp. really synchronizing with 
the IMAP server 

With 1.6 it doesn't work. With 1.5 it worked. But in remember that in at least 
one former version, it didn't work either. So my impression is that in one 
Mozilla version the error is there, and in some other it's not. Like 
changing... 
I know WEB.DE doesn't provide a standard conform IMAP server, but as I said - 
before it worked in some versions.

Comment 1

15 years ago
Reporter, could you generate an IMAP protocol log as described in
http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap
and attach it to this bug?

Thanks.
(Reporter)

Comment 2

15 years ago
Created attachment 139657 [details]
IMAP log file

Activated logging on level 5, opened Mozilla, checked for new mail, entered the
folders with apparently new mail, read new mail, chose folder "Fun", checked
for new mail again, re-entered folder "keingeld", re-entered folder "Fun",
checked for new mail and so on.

Every time Mozilla checks for new mail it resets the number of new messages to
the old value...
(Assignee)

Comment 3

15 years ago
Can you try a recent 1.7 trunk build? I believe this is fixed. It looks to me
like what's going on is that you have some messages that are /DELETED but not
/SEEN, and that causes the STATUS message count to be off. The way we fixed this
in 1.7 is that when we delete or move a message, we also mark it as /SEEN, and
the counts get fixed. You can verify this by doing a File | Compact All Folders
on your imap account, which will expunge the deleted messages, and make the
counts right.

Or, you can keep using 1.6 and use about:config to set the following pref to
false: "mail.imap.use_status_for_biff" - this should restore the pre 1.6
behaviour. But I would really appreciate it if you could try 1.7 and verify that
this fixed in 1.7. Thx!
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

15 years ago
(In reply to comment #3)
> Can you try a recent 1.7 trunk build? I believe this is fixed. 
Had the same problem as reported in original description when switching from 1.5
to 1.6, but using Windows 2000. 
Now using "Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7a)
Gecko/20040202", behaviour for my IMAP folders is again as expected (and as
before (1.5)).
(Assignee)

Comment 5

15 years ago
thx, marking wfm, then, since it's working in 1.7
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.