Closed Bug 231814 Opened 21 years ago Closed 21 years ago

Mozilla blocks and hangs during message download

Categories

(MailNews Core :: Backend, defect)

Sun
SunOS
defect
Not set
critical

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: beanladen, Assigned: Bienvenu)

References

Details

(Keywords: regression)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.6) Gecko/20040116
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.6) Gecko/20040116

During download of larger messages (POP3), Mozilla 1.6 completely hangs and 
blocks until a message has been completely retrieved (about 15 sec/100kb; we 
are in a switched 100MB Network with Gigabit connection to the mailserver, so 
the download time is suprisingly long, anyway). This is a regression from 1.5,
we didn't test 1.6a/b. 
We are using the Sun - contributed Mozilla version, not R.Mainz' XPrint-only 
build.

Reproducible: Always

Steps to Reproduce:
1.download message in mailnews or configure for automatic download



Actual Results:  
Mozilla blocks and hangs a while for every larger message


Expected Results:  
Download in the background without blocking (and a bit faster than now) like
in 1.4/5


This problem is usually annoying with larger attachments and is a real 
showstopper when it comes to Megs of PDFs or the like.
Keywords: regression
Note:.mozilla stays on an NFS mounted filesystem. Download speed has dropped
to 10k/s .
This could be bug 139576 again (OS=MAC is misleading!), which was fixed 
for a long while.
apparently this is caused by the seek to the eof call, which I guess on NFS is
very slow, even when we're at eof (it might be the flush call). This call was
put in to make sure we're writing new mail to the end of the file in case
someone has changed the file pos out from under us...I'll try to see how I can
fix this.
Assignee: sspitzer → bienvenu
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attached patch proposed fixSplinter Review
don't seek unless we're not at eof.
Attachment #139669 - Flags: superreview?(mscott)
Attachment #139669 - Flags: superreview?(mscott) → superreview+
can you try tomorrow's 1.7 trunk build and let me know if this is fixed for you?
thx.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
I'll try, if there's a Solaris/Sparc build tomorrow. Thanks for the fast fix !
This is fixed for the newest Solaris 1.7a trunk. Speed is up again to about
150kB/s. Mozilla still blocks during download, but this is now only noticable
for messages > 2MB. Maybe this should be fixed by threading the download so 
that the browser does not block at all => future enhancement.
(Unfortunately the trunk Solaris2.8 build is not usable for us, since Mr.Mainz
has his fingers in the build configurator again and disabled the postscript
module. I think this shouldn't be allowed for trunk development builds, this
effectively blocks the testing and enhancement of the postscript module. And
it has been proven that switching on both XPrint and Postscript does not harm
anyone. Can someone please stop the dictatorship of Roland Mainz, at least
for the main trunk line ?)
beanladen@arcor.de I guess this was your last fake bug. I am going to get your
bugzilla account removed since you do not stop stalking platform EVEN BEING
ASKED TO DO SO MULTIPLE TIMES.
marking verified.
Status: RESOLVED → VERIFIED
beanladen@arcor.de:
> We are using the Sun - contributed Mozilla version, not R.Mainz' XPrint-only 
> build.

This is impossible. The sun contributed builds have serious stability problems
and are not fully operational.
I doubt you were using it to test this bug.
So far - AGAIN YOU HAVE BEEN PROVEN TO BE A LIAR.

> this effectively blocks the testing and enhancement of the postscript module.

What development? The postscript module was not being enhanced since about 2
years and bugs were filed to get rid of it for all platforms. There is no
further enhancement in this part of mozilla.

So far - bye-bye TROLL! Hopefully we get rid of you soon.
Commenter's #7 and #9:
Please comment on the subject of the bug, not of that of another bug (although
I did in this bug, but at least in braces...).
Facts: The bug appeared in the Sun contributed build 1.6, which is running 
at our institute and used by a couple of people with only minor complaints 
since version 1.4.0 (we do not use Xprint, so guess with what the people at 
our institute are printing with...). The stability of versions before that were 
highly dependent on libraries installed, and I had some bugs on this issue, 
and sometimes trouble to finally get the right libraries to run 1.4.0 in
production quality. The fix was tested with the Mainz contributed build 
from last night, since no Sun Forte build is available for the trunk, but 
that's not relevant for the bug. Nevertheless, because of the Xprint issue 
we will not use that for daily work, instead, I'm now compiling my own Forte
build (really ! But it's not easy with the old 6.2 CC compiler).
So if you don't believe me: Our institute is Forschungszentrum Karlsruhe,
Institute for Meteorology and Climate Research, group algorithm and method 
development, we are part of the satellite project ENVISAT/MIPAS of ESA,
I'm the chief programmer and development coordinator in that group, I have a
PhD in theoretical Astrophysics, and I'm a bit older than anyone of you, we 
have about 14 Ultra 5 and Blade 100 Sun Workstations, 2 E450, 1 E4500, 2 E280,
1 DS25, and a large TruCluster of 9 ES40 Alpha machines (which I built up and
administer), and you can visit us and have a look at running Forte Mozilla 
builds (and how they print with a "completely nonfunctional" postscript module).
If anyone still believes that I'm telling fairytales about bugs here, please 
shut up and make your own experiences (I have 23 years now, and still I feel 
that I'm learning new things every day) before commenting and **** on 
people, especially on Pete Zha from Sun, who does a great job to contribute 
those Forte builds (with BOTH postscript and Xprint) which work.
It seems like there are guys commenting here who never have seen a Sun,
and obviously have no technical background, and probably never had a formal
education in informatics or natural sciences, at most a hobbyist view on
what they think they are experts in (I'm NOT an expert for Mozilla, despite
of my professional skills in programming and related things). And they 
obviously do not follow the bugs they may have seen on bugzilla, otherwise 
they would know that development has proceeded and most of the bugs they 
may have in mind are years old and long fixed, or have a description how to 
get around. And obviously they have not tried Forte builds for years now, 
esp. commenter #9 (if you need the very details how we DO RUN the Forte 
builds, I can help you, in spite of your unfriendly comments).
Sorry for the lengthy Spam, David, but sometimes I get in rage when I must 
read such garbage from mentally disordered people, and I think you may also
a bit surprised that you just fixed a virtual bug which even could not have 
existed at all ;-)
fixed on the m4 branch.
Blocks: 230700
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: