cnet.com - Most/all CNET stories have a fixed height on the first paragraph

RESOLVED FIXED

Status

RESOLVED FIXED
15 years ago
4 years ago

People

(Reporter: jesup, Unassigned)

Tracking

({top500})

Details

(URL)

(Reporter)

Description

15 years ago
Most or all CNET stories have a fixed height on the first paragraph's <div> tag
-- in this case:

<div
style="background:url(http://i.i.com.com/cnwk.1d/i/ts/ces/2004/ces_editor_blecher.jpg);
height:275px">

If the font size is not as expected (larger), the text will overflow the div and
be covered/lost to the following DIV.  Mozilla respects the absolute DIV size
and doesn't move the following DIV.

Note that IE appears to move the following DIV down to account for the overflow
of the absolute-sized div (or if you prefer, bump the size of the overflowed div
up) when you increase the text size, which is probably why they didn't notice this.
(Reporter)

Comment 1

15 years ago
To reproduce, load the page and then increase the font size.

I'm assuming this is not a layout bug, and that an overflowed absolute-height
DIV should not shift following div's (though IE appears to).  If I'm wrong, let
me know.

I'm also reporting this to CNET via their webform.  There's no direct category
for this, so I'm using "other" and asking it be sent to their web template
maintainers.

Updated

14 years ago
Keywords: top500

Comment 2

14 years ago
Conforming summary to TFM item 10 at 
http://www.mozilla.org/projects/tech-evangelism/site/procedures.html#file-new
Summary: Most/all CNET stories have a fixed height on the first paragraph → cnet.com - Most/all CNET stories have a fixed height on the first paragraph
(Reporter)

Comment 3

9 years ago
It appears that we now move the following DIV, since the page still has the absolute div, but increasing the font size bumps stuff down (like IE)>
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.