View|Sort|By Flag does not work properly

VERIFIED WORKSFORME

Status

defect
P3
normal
VERIFIED WORKSFORME
20 years ago
11 years ago

People

(Reporter: fenella, Assigned: scottputterman)

Tracking

Trunk
Future
Other
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
Linux Redhat 6.0 (2000-01-05-15 M13)
Steps:
1. Launch Messenger using the -mail option
2. Select a IMAP (or POP) account
3. From the Inbox, make sure there exist some messages with Flag icon turned on.
4. Select View|Sort|By Flag

Actual result: No response, messages do not sort by Flag.
Expected result: Messages should be sorted by flag

5. When I click on the Flag column,
Actual result: it sorts only one way (The flagged messages are on top.)
Expected result: message should be sorted both accending and decending
Note: Please let me know if this needs a separate bug.

This occurs both in POP and IMAP.

Can not test Win32 and Mac because re-spin has not come yet.
(Reporter)

Updated

20 years ago
Summary: [Regression]View|Sort|By Flag does not work properly → View|Sort|By Flag does not work properly
(Reporter)

Updated

20 years ago
QA Contact: lchiang → fenella
(Reporter)

Comment 1

20 years ago
Linux Redhat 6.0 (2000-01-11-09 M13)
Win_nt 4.0 (2000-01-11-09 M13)
Re-test this bug using 1/11 builds. It happens on both platforms in POP and IMAP
accounts.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M18
(Reporter)

Comment 2

19 years ago
Linux and Win32 (2000-05-23-10 M16)
Mac (2000-05-23-12 M16)
View|Sort|By Flag has been inactivated.  A .(dot) is in front of it.
(Assignee)

Comment 3

19 years ago
We either need to make it work or take out the menu item.
Keywords: correctness, nsbeta3
(Assignee)

Updated

19 years ago
Keywords: mail2
(Assignee)

Comment 4

19 years ago
Mail triage marking nsbeta3-. 

I will open a new bug to track removing of the menu item.
Whiteboard: [nsbeta3-]
Target Milestone: M18 → Future
(Assignee)

Comment 5

19 years ago
sorry for the extra email. Removing mail2 keyword.
Keywords: mail2
(Assignee)

Comment 6

19 years ago
this has been partly fixed.  If you sort a folder after loading, without
changing flags on any messages then it will sort correctly. However, if you
flag/unflag messages in the folder and then sort then it won't work.

Updated

18 years ago
QA Contact: fenella → laurel
(Assignee)

Comment 7

18 years ago
looks like this got fixed with the outliner rewrite.  Marking worksforme.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Keywords: nsbeta3
Resolution: --- → WORKSFORME
Whiteboard: [nsbeta3-]

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 8

18 years ago
OK using oct31 commercial trunk build.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.