mime type is text/plain extension is registered by plugin mplayerplug-in, but file is downloaded rather than passed to plugin

VERIFIED INVALID

Status

Plugins Graveyard
Mplayer
VERIFIED INVALID
14 years ago
2 years ago

People

(Reporter: kdekorte, Assigned: Peter Lubczynski)

Tracking

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031110 Firebird/0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031110 Firebird/0.7

It appears that when the mime type of a file is being downloade and the type is
text/plain mozilla should check the extension of the file be downloaded in
NP_FULL mode and the look in the list of extensions supported by the plugins and
if the extension matches one handled by a plugin the url should be passed to the
plugin for processing

Reproducible: Always

Steps to Reproduce:
1. Install Firebird 0.7
2. Install mplayerplug-in  (http://mplayerplug-in.sf.net
3. Visit http://alxxx.altervista.org/video.wmv

Actual Results:  
The file is downloaded into the browser window

Expected Results:  
URL should be passed to the plugin for processing.

Comment 1

14 years ago
Can you try this with a nightly branch build?   I know there's a fix for this at
least for Win32...
(Reporter)

Comment 2

14 years ago
Tried with both Firebird and Mozilla nightly builds. Behavior is different.
Mozilla pops up a dialog saying I don't know what to do with mime type
application/octet-stream and then asks if I want to save the file or cancel. So
it is better, but not quite what I expect.

fix your server, we aren't going to make this workaround even more extensive.

Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

14 years ago
Not my server, but I get bug reports for the plugin due to this issue. I'm still
wondering why you need to put suffix's with the mime type that the plugin
handles cause it looks like the suffix is never used.
local files, ftp, HTTP servers that send no content type
Verified.
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: Plug-ins → Mplayer
Product: Core → Plugins
QA Contact: mplayer
Version: Trunk → unspecified
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.