Nested tables & 'table-layout:fixed;' fail to render inner content.

VERIFIED DUPLICATE of bug 10269

Status

()

Core
Layout: Tables
P3
normal
VERIFIED DUPLICATE of bug 10269
18 years ago
18 years ago

People

(Reporter: John Morrison, Assigned: karnaze (gone))

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
So, on bug #22765, buster suggested using 'table-layout: fixed;' to test an
aspect of a problem involving misplaced paint of form controls inside nested
tables (not the solution, just an experiment).

Unfortunately, my experiment resulted in exposing this _unrelated_ problem.

Overview Description:
  Nested tables with 'table-layout: fixed;' fail to render inner content.

Steps to Reproduce:

1) Load up the attachment (to follow) -- first set of nested tables has
   'table-layout: fixed;', second set does not.

Actual Results: if 'table-layout: fixed;', the word "inner" is not visible.

Expected Results: the word inner should be visible in both sets of nested
                  tables.

Build Date & Platform Bug Found: 2000010416 win95

Additional Builds and Platforms Tested On: no others tested

Additional Information:
  I'll ponder the various permutations of this situation; if I haven't
  attached additional testcase and you want them, give me a wake-up call.
(Reporter)

Comment 1

18 years ago
Created attachment 3992 [details]
testcase; nested tables with 'table-layout: fixed' and without
(Reporter)

Comment 2

18 years ago
I think I had too many stupid pills for breakfast ... This doesn't require
nested tables, and it may be that I've forgotten the rules for 'table-layout:
fixed;'. I'll go re-read the relevant info; ignore this bug for now.
(Reporter)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

18 years ago
This is just bug #10269 -- i.e., how to handle table-layout: fixed, when
the table width and all first row columns have auto width. Marking DUPLICATE.

*** This bug has been marked as a duplicate of 10269 ***

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 4

18 years ago
Verified dup of #10269 per reporter's comments
You need to log in before you can comment on or make changes to this bug.