Custom Keywords in Location Bar (like google, dict)

RESOLVED INVALID

Status

()

--
enhancement
RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: harrisonchen, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040114 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040114 Firebird/0.7+

I was wondering if Firebird could have a feature like Opera, where you can make
your own custom searches built into MFirebird.  That was poorly worded, sorry, so
I'll give an example.

All search engines use querys.  So could there be a feature where you could
program in a keyword into a query?  For instance:

If I typed in "google" in the URL bar then a space and told Mozilla beforehand
that if "google" was the first thing in the address bar, it would append what
came after it to http://www.google.com/search?&q= (and parse it as necessary)
and go there.  This has been done in Firebird already, but only with Google and
Dictionary.com (and some others, such as Amazon).  But sometimes there are other
sites where I would like Firebird to be able to do this for as well, so it would
be nice if there was some interface where the user could define these keywords.

I know I posted this in the Mozilla section, but I think it could be used in
Firebird as well.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Updated

15 years ago
OS: Windows XP → All
Hardware: PC → All
Summary: custom search keywords → Custom Keywords in Location Bar (like google, dict)

Comment 1

15 years ago
Firebird already has this feature, as part of bookmarks.  Give a bookmark a
keyword, and make the URL contain a %s, e.g. http://www.google.com/search?&q=%s.
 %s will be replaced by whatever you type after the keyword in the address bar.

http://www.mozilla.org/docs/end-user/keywords.html

Comment 2

15 years ago
Marking invalid. If we're misunderstanding what you want, reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 3

15 years ago
He means that he wants to be able to enter custom keywords in the Location Bar,
like when you type "google blah" in the Location Bar and it searches for blah on
Google.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 4

15 years ago
Yeah. You can do that already. What enhancement is there to be made?

Comment 5

15 years ago
I believe the reporter is asking for adding *custom* keywords. For example, to
be able to define something like oxford as a keyword, and then typing something
like "oxford random" in the Location Bar, and then having it search for the word
"random" in the Oxford English Dictionary.

Comment 6

15 years ago
Yes, you can do that! Look at Jesse's link!

Comment 7

15 years ago
Okay, I'm feeling stupid now, having confused comment 1 with the original
bugreport. Sorry about the confusion.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → INVALID
(Reporter)

Comment 8

15 years ago
Sorry.

I didn't know you could already do it.

Comment 9

15 years ago
*** Bug 234589 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.