Automatically moving to next bug in list after modifying bug stopped working

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: dominic.berzins, Unassigned)

Tracking

2.16.4
x86
Windows 2000

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
Build Identifier: 

Bugzilla 2.16.4:

After turning on 'usebuggroups', the  'automatically moving to next bug in bug 
list' has stopped working.  The page now displayed after modifying a bug looks 
like the 'end of buglist' page.

This was working fine until UseBugGroups was switched on.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Updated

15 years ago
Version: unspecified → 2.16.4
never heard this before, and 2.16.x has been out a long time.  Have you actually
run a query since then?  So you have cookies on?
(Reporter)

Comment 2

15 years ago
yep, queries are generated as normal. and all bugs are in the bug lists. when 
i've submitted a change, and it then goes to the 'last' page - i can still 
click on Show List and all bugs are listed.

and while viewing one of the bugs in a bug list, the Previous and Next buttons 
function normally.

cookies are still on.

i've checked with the person who turned Groups on, and it seems that nothing 
else was changed. and we have tested switching Groups back off - but that 
didn't seem to rectify the problem.
The very bottom of the process_bug.cgi script looks like this in the distribution:


# Show next bug, if it exists.
if ($::COOKIE{"BUGLIST"} && $::FORM{'id'}) {
    my @bugs = split(/:/, $::COOKIE{"BUGLIST"});
    $vars->{'bug_list'} = \@bugs;
    my $cur = lsearch(\@bugs, $::FORM{"id"});
    if ($cur >= 0 && $cur < $#bugs) {
        my $next_bug = $bugs[$cur + 1];
        if (detaint_natural($next_bug) && CanSeeBug($next_bug)) {
            $::FORM{'id'} = $next_bug;

            $vars->{'next_id'} = $next_bug;

            # Let the user know we are about to display the next bug in their list.
            $template->process("bug/process/next.html.tmpl", $vars)
              || ThrowTemplateError($template->error());

            show_bug("header is already done");

            exit;
        }
    }
}

# End the response page.
$template->process("bug/navigate.html.tmpl", $vars)
  || ThrowTemplateError($template->error());
$template->process("global/footer.html.tmpl", $vars)
  || ThrowTemplateError($template->error());


Does yours still look like that?
Private email from Dominic:

> yep... our process_bug.cgi is identical.

Not posting his entire email because there was stuff outside the scope of this
bug in it as well.
For the record, I can't reproduce this on either of
http://landfill.bugzilla.org/bugzilla-2.16.4/ or
http://landfill.bugzilla.org/bugzilla-2.16-branch/

Troubleshooting hint:

In this chunk of code:

# Show next bug, if it exists.
if ($::COOKIE{"BUGLIST"} && $::FORM{'id'}) {

Change that to look like this:

# Show next bug, if it exists.
warn "cookie = " . $::COOKIE{"BUGLIST"} . "\n";
warn "if = " . $::FORM{'id'} . "\n";
if ($::COOKIE{"BUGLIST"} && $::FORM{'id'}) {

Then try to make a change to a bug that's in a list again and see what the
output of those two lines shows in the webserver's error log.
(Reporter)

Comment 6

15 years ago
Here are the results...

[Tue Jan 27 12:16:14 2004] [error] [client 203.14.101.2] cookie = 
10986:11921:11924:11910:10985
[Tue Jan 27 12:16:14 2004] [error] [client 203.14.101.2] [Tue Jan 27 12:16:14 
2004] process_bug.cgi: cookie = 10986:11921:11924:11910:10985
[Tue Jan 27 12:16:14 2004] [error] [client 203.14.101.2] if = 10986
[Tue Jan 27 12:16:14 2004] [error] [client 203.14.101.2] [Tue Jan 27 12:16:14 
2004] process_bug.cgi: if = 10986
(Reporter)

Comment 7

15 years ago
Does that error log indicate anything?
Yeah, that error log indicates you're getting the correct bug_id and buglist
passed through...  my next guess based on the fact that this started when you
turned on UseBugGroups is that CanSeeBug() isn't working right.

Can you try adding a warn to display the results of CanSeeBug just before the
if() in there?

        my $next_bug = $bugs[$cur + 1];
+       detaint_natural($next_bug) && warn "CanSeeBug = " . CanSeeBug($next_bug);
        if (detaint_natural($next_bug) && CanSeeBug($next_bug)) {
OK, received the following in email from Dominic because it had internal URLs in
it...   reproducing here with said URLs stripped:

From: D, B
Sent: Tuesday, March 09, 2004 4:55 PM
To: Berzins, Dominic
Subject: Bugzilla 2.16.4 / Dave Miller debug lines & bug 231899


Hi Dominic,

Here y'go! 

This is the output from the httpd error log
with both sets of debug lines
as suggested by Dave Miller as per bug 231899.

Looks like CanSeeBug($next_bug) is empty...

cheers,

B.

[Tue Mar 09 16:48:11 2004] [error] [client 203.200.43.67] cookie =
14767:14940:15194:15195:15196:15197:15198:15199:15200:15201:15285:15287:1528
9:15292:15294:15295:15296:15297:15298:15299:15300:15301:15302:15303:15304:15
305:15340:15341:15346:15359:15384:15386:15396:15397:15398:15399:15400:15401:
15402:15403:15404:15405:15406:15407:15408:16100:16180:16181:16182:16183:1618
4:16185:16186:16187:16188:16189:16190:16191:16192:16271:16272:16273:16274:16
276:16277:16279:16280:16281:16282:16315:16316:16318:16320:16322:16329:16330:
16331:16333:16345:16352:16354:16355:16356:16366:16371:16372:16376:16379:1638
1:16382:16384:16385:16386:16388:16390:16391:16392:16393:16394:16395:16396:16
472:16475:16478:16487:16509:16511:16514:16516:16517:16522:16523:16732:16733:
16734:16736:16737:16738:16739:16740:16741:16742:16743:16744:16746:16748:1674
9:16750:16751:16752:16753:16754:16755:16756:16757:16820:16824:16828:16836:16
843:16844:16845:16848:16849:17438:17441:17442:17443:17446:17447:17448:17449:
17450:1816!
0:18161
[Tue Mar 09 16:48:11 2004] [error] [client 203.200.43.67] [Tue Mar  9 16:48:11
2004] process_bug.cgi: cookie =
14767:14940:15194:15195:15196:15197:15198:15199:15200:15201:15285:15287:1528
9:15292:15294:15295:15296:15297:15298:15299:15300:15301:15302:15303:15304:15
305:15340:15341:15346:15359:15384:15386:15396:15397:15398:15399:15400:15401:
15402:15403:15404:15405:15406:15407:15408:16100:16180:16181:16182:16183:1618
4:16185:16186:16187:16188:16189:16190:16191:16192:16271:16272:16273:16274:16
276:16277:16279:16280:16281:16282:16315:16316:16318:16320:16322:16329:16330:
16331:16333:16345:16352:16354:16355:16356:16366:16371:16372:16376:16379:1638
1:16382:16384:16385:16386:16388:16390:16391:16392:16393:16394:16395:16396:16
472:16475:16478:16487:16509:16511:16514:16516:16517:16522:16523:16732:16733:
16734:16736:16737:16738:16739:16740:16741:16742:16743:16744:16746:16748:1674
9:16750:16751:16752:16753:16754:16755:16756:16757:16820:16824:16828:16836:16
843:16844:16845:16848:16849:17438:17441:17!
442:17443:17446:17447:17448:17449:17450:18160:18161
[Tue Mar 09 16:48:11 2004] [error] [client 203.200.43.67] if = 16382
[Tue Mar 09 16:48:11 2004] [error] [client 203.200.43.67] [Tue Mar  9 16:48:11
2004] process_bug.cgi: if = 16382
[Tue Mar 09 16:48:11 2004] [error] [client 203.200.43.67] CanSeeBug =  at
/var/www/bugzilla-2.16.4/process_bug.cgi line 1341.
[Tue Mar 09 16:48:11 2004] [error] [client 203.200.43.67] [Tue Mar  9 16:48:11
2004] process_bug.cgi: CanSeeBug =  at /var/www/bugzilla-2.16.4/process_bug.cgi
line 1341.
[Tue Mar 09 16:48:14 2004] [error] [client 203.14.101.2] cookie =
11910:11921:11924:10986:10985
[Tue Mar 09 16:48:14 2004] [error] [client 203.14.101.2] [Tue Mar  9 16:48:14
2004] process_bug.cgi: cookie = 11910:11921:11924:10986:10985
[Tue Mar 09 16:48:14 2004] [error] [client 203.14.101.2] if = 11924
[Tue Mar 09 16:48:14 2004] [error] [client 203.14.101.2] [Tue Mar  9 16:48:14
2004] process_bug.cgi: if = 11924
[Tue Mar 09 16:48:14 2004] [error] [client 203.14.101.2] CanSeeBug =  at
/var/www/bugzilla-2.16.4/process_bug.cgi line 1341.
[Tue Mar 09 16:48:14 2004] [error] [client 203.14.101.2] [Tue Mar  9 16:48:14
2004] process_bug.cgi: CanSeeBug =  at /var/www/bugzilla-2.16.4/process_bug.cgi
line 1341.
[Tue Mar 09 16:49:57 2004] [error] [client 203.200.43.67] cookie =
14767:14940:15194:15195:15196:15197:15198:15199:15200:15201:15285:15287:1528
9:15292:15294:15295:15296:15297:15298:15299:15300:15301:15302:15303:15304:15
305:15340:15341:15346:15359:15384:15386:15396:15397:15398:15399:15400:15401:
15402:15403:15404:15405:15406:15407:15408:16100:16180:16181:16182:16183:1618
4:16185:16186:16187:16188:16189:16190:16191:16192:16271:16272:16273:16274:16
276:16277:16279:16280:16281:16282:16315:16316:16318:16320:16322:16329:16330:
16331:16333:16345:16352:16354:16355:16356:16366:16371:16372:16376:16379:1638
1:16382:16384:16385:16386:16388:16390:16391:16392:16393:16394:16395:16396:16
472:16475:16478:16487:16509:16511:16514:16516:16517:16522:16523:16732:16733:
16734:16736:16737:16738:16739:16740:16741:16742:16743:16744:16746:16748:1674
9:16750:16751:16752:16753:16754:16755:16756:16757:16820:16824:16828:16836:16
843:16844:16845:16848:16849:17438:17441:17442:17443:17446:17447:17448:17449:
17450:1816!
0:18161
[Tue Mar 09 16:49:57 2004] [error] [client 203.200.43.67] [Tue Mar  9 16:49:57
2004] process_bug.cgi: cookie =
14767:14940:15194:15195:15196:15197:15198:15199:15200:15201:15285:15287:1528
9:15292:15294:15295:15296:15297:15298:15299:15300:15301:15302:15303:15304:15
305:15340:15341:15346:15359:15384:15386:15396:15397:15398:15399:15400:15401:
15402:15403:15404:15405:15406:15407:15408:16100:16180:16181:16182:16183:1618
4:16185:16186:16187:16188:16189:16190:16191:16192:16271:16272:16273:16274:16
276:16277:16279:16280:16281:16282:16315:16316:16318:16320:16322:16329:16330:
16331:16333:16345:16352:16354:16355:16356:16366:16371:16372:16376:16379:1638
1:16382:16384:16385:16386:16388:16390:16391:16392:16393:16394:16395:16396:16
472:16475:16478:16487:16509:16511:16514:16516:16517:16522:16523:16732:16733:
16734:16736:16737:16738:16739:16740:16741:16742:16743:16744:16746:16748:1674
9:16750:16751:16752:16753:16754:16755:16756:16757:16820:16824:16828:16836:16
843:16844:16845:16848:16849:17438:17441:17!
442:17443:17446:17447:17448:17449:17450:18160:18161
[Tue Mar 09 16:49:57 2004] [error] [client 203.200.43.67] if = 16384
[Tue Mar 09 16:49:57 2004] [error] [client 203.200.43.67] [Tue Mar  9 16:49:57
2004] process_bug.cgi: if = 16384
[Tue Mar 09 16:49:57 2004] [error] [client 203.200.43.67] CanSeeBug =  at
/var/www/bugzilla-2.16.4/process_bug.cgi line 1341.
[Tue Mar 09 16:49:57 2004] [error] [client 203.200.43.67] [Tue Mar  9 16:49:57
2004] process_bug.cgi: CanSeeBug =  at /var/www/bugzilla-2.16.4/process_bug.cgi
line 1341.
(Reporter)

Comment 10

15 years ago
does the new information suggest anything?
(Reporter)

Comment 11

15 years ago
update:  i have got the 'automatically moving to next bug' to work again.

after turning UseBugGroups off, i had to delete the group associated with each 
product.

so i went to:  Groups. then chose the Delete option on the RHS of the product. 
after then selecting the 3 check-boxes to confirm i did want to delete the 
groupness, it started working again.

definately a bug - if you cannot have groups switched on, and be able to move 
between bugs automatically after modifying one.
I have groups enabled on every Bugzilla I run and I've never seen this (we have
them enabled on bugzilla.mozilla.org even)
I still can't find a way to duplicate this, and I have no idea what you were
hitting.  The logfiles you sent basically show nothing except that CanSeeBug
isn't returning correct results, but I can't seem to make it fail anywhere else...
Reassigning bugs that I'm not actively working on to the default component owner
in order to try to make some sanity out of my personal buglist.  This doesn't
mean the bug isn't being dealt with, just that I'm not the one doing it.  If you
are dealing with this bug, please assign it to yourself.
Assignee: justdave → query-and-buglist
QA Contact: mattyt-bugzilla → default-qa

Comment 15

14 years ago
Yeah, and I don't recall anybody else ever reporting this. Maybe there's a local
customization of your CanSeeBug?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.