bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Crash when trying to open 'javascript:' in File-Open File Dialogue

RESOLVED INVALID

Status

SeaMonkey
General
--
critical
RESOLVED INVALID
15 years ago
14 years ago

People

(Reporter: Matti, Unassigned)

Tracking

({crash})

Trunk
x86
Windows 2000
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113

Mozilla crashes when you try to open " javascript: " in the File-Open Dialogue.


Reproducible: Always

Steps to Reproduce:
1. Click on File-Open File
2. Enter:  javascript:
3. Watch it crash (seems like the quality feedback agent dies then aswell....)

Actual Results:  
Crash :(

Expected Results:  
Display an error that there is no such file.

Comment 1

15 years ago
wfm current cvs trunk build on win2k
anyway i think this doesn't depend on the build very much, since this dialog is
a native windows one. Here it says "[path]: The filename is not valid"
Have you some ServicePack installed (i got ServicePack 4)?
Worksforme, with linux trunk build 2004-01-22-07.  Is this a problem with the
Windows filepicker in particular?

Updated

15 years ago
Severity: normal → critical
Keywords: crash

Comment 3

15 years ago
WFM, WinXP SP1 Moz 1.6. "Javascript: The above filename is invalid."

Comment 4

15 years ago
Crashes reproducably here with a fresh Mozilla Nightly: Mozilla 1.7a
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7a) Gecko/20040125 and
Mozilla 1.6

I was using a fresh profile. Steps as detailed in the bug report.

Comment 5

15 years ago
WFM Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040126 Firebird/0.7+

Comment 6

15 years ago
WFM, must be somethin with the windows file chooser.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7a) Gecko/20040127
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

Comment 7

15 years ago
crashes: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007
Firebird/0.7

almost instant crash, did not hang

Comment 8

15 years ago
also crashed,
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113

Comment 9

15 years ago
WFM with 1.6 standard zip build on Win 2000
also WFM with mid-January cvs debug build (als Win2k)

Comment 10

15 years ago
Ok, what Windows versions, including Service Packs? Anyone have it crashing on
WinXP SP1 or Win2K SP4?

Comment 11

15 years ago
WFM Win2k SP3
Reporter: Do you also crash when you enter "javascript:" in the File-Open Dialog
of Notepad or another application that uses the File Open dialog?
(Reporter)

Comment 13

15 years ago
I tried it in a couple of other applications. Some do crash, some dont.
Notepad does. Adobe Acrobat does too. mIRC does :)
Microsoft Word does not but displays an error.

I'm using Win2k SP3

Could actually be a file picker problem as word seems to have an own window
which looks different to the others...
But I'm not at all familiar with developing those things so I cant argue if
there's anything moz could actually do about it....
WFM on WinXP SP1/2 trunk 2004022909.
It seems this is an Win2k SP1,2 and/or 3 issue then.

Comment 15

15 years ago
Reproduced on Win2000 SP4, Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US;
rv:1.7b) Gecko/20040316

Talkback incident ID: TB8379E

Can also crash notepad, wordpad etc. this way, so it seems to be a Windows
related problem.

Comment 16

15 years ago
 SHELL32.dll + 0xb9357 (0x783a9357)
SHELL32.dll + 0xb959b (0x783a959b)
SHELL32.dll + 0xb979b (0x783a979b)
SHELL32.dll + 0xb98db (0x783a98db)
comdlg32.dll + 0x267ec (0x76b567ec)
comdlg32.dll + 0x266b9 (0x76b566b9)
comdlg32.dll + 0x8397 (0x76b38397)
comdlg32.dll + 0x4824 (0x76b34824)
comdlg32.dll + 0x4727 (0x76b34727)
USER32.dll + 0x2a2d0 (0x77e3a2d0)
USER32.dll + 0x18c1b (0x77e28c1b)
USER32.dll + 0x558a (0x77e1558a)
ntdll.dll + 0x215ef (0x77fa15ef)
USER32.dll + 0x7341 (0x77e17341)
USER32.dll + 0x1eda6 (0x77e2eda6)
USER32.dll + 0x2340e (0x77e3340e)
USER32.dll + 0x33f21 (0x77e43f21)
USER32.dll + 0x28bb1 (0x77e38bb1)
USER32.dll + 0x2eaad (0x77e3eaad)
comdlg32.dll + 0x5324 (0x76b35324)
comdlg32.dll + 0x64cf (0x76b364cf)
comdlg32.dll + 0xed99 (0x76b3ed99)
nsFilePicker::ShowW
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsFilePicker.cpp,
line 240]
nsFilePicker::Show
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsFilePicker.cpp,
line 369]
XPTC_InvokeByIndex
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp,
line 102]
XPCWrappedNative::CallMethod
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp,
line 2029]
XPC_WN_CallMethod
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 1288]
js_Invoke
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/js/src/jsinterp.c,
line 943]
js_Interpret
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/js/src/jsinterp.c,
line 2963]
js_Invoke
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/js/src/jsinterp.c,
line 959]
js_InternalInvoke
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/js/src/jsinterp.c,
line 1036]
JS_CallFunctionValue
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/js/src/jsapi.c, line
3591]
nsJSContext::CallEventHandler
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/dom/src/base/nsJSEnvironment.cpp,
line 1269]
nsJSEventListener::HandleEvent
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/dom/src/events/nsJSEventListener.cpp,
line 181]
nsEventListenerManager::HandleEventSubType
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/content/events/src/nsEventListenerManager.cpp,
line 1435]
nsEventListenerManager::HandleEvent
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/content/events/src/nsEventListenerManager.cpp,
line 1512]
nsXULElement::HandleDOMEvent
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/content/xul/content/src/nsXULElement.cpp,
line 2851]
nsXULElement::HandleDOMEvent
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/content/xul/content/src/nsXULElement.cpp,
line 2687]
PresShell::HandleDOMEventWithTarget
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsPresShell.cpp,
line 6097]
nsMenuFrame::Execute
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/layout/xul/base/src/nsMenuFrame.cpp,
line 1651]
nsMenuFrame::HandleEvent
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/layout/xul/base/src/nsMenuFrame.cpp,
line 443]
PresShell::HandleEventInternal
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsPresShell.cpp,
line 6067]
PresShell::HandleEvent
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/layout/html/base/src/nsPresShell.cpp,
line 5942]
nsViewManager::HandleEvent
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/view/src/nsViewManager.cpp,
line 2281]
nsViewManager::DispatchEvent
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/view/src/nsViewManager.cpp,
line 2025]
HandleEvent
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/view/src/nsView.cpp,
line 79]
nsWindow::DispatchEvent
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsWindow.cpp,
line 1068]
nsWindow::DispatchWindowEvent
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsWindow.cpp,
line 1085]
nsWindow::DispatchMouseEvent
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsWindow.cpp,
line 5225]
ChildWindow::DispatchMouseEvent
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsWindow.cpp,
line 5478]
nsWindow::ProcessMessage
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsWindow.cpp,
line 4063]
nsWindow::WindowProc
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsWindow.cpp,
line 1347]
USER32.dll + 0x2a2d0 (0x77e3a2d0)
USER32.dll + 0x45e5 (0x77e145e5)
USER32.dll + 0xa816 (0x77e1a816)
nsAppShellService::Run
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/xpfe/appshell/src/nsAppShellService.cpp,
line 524]
main1
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/xpfe/bootstrap/nsAppRunner.cpp,
line 1308]
main
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/xpfe/bootstrap/nsAppRunner.cpp,
line 1712]
WinMain
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/xpfe/bootstrap/nsAppRunner.cpp,
line 1734]
WinMainCRTStartup()
KERNEL32.DLL + 0x287e7 (0x7c5987e7)
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 17

15 years ago
Erik's Stack proves (and various comments indicate so): this is a Windows bug.
Over to Microsoft. ;-)
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.